Skip to Content
author's profile photo Former Member
Former Member

How would I delete a background job?

Dear Friends,

Some time ago, I was able to schedule a job that runs daily. The thing is, I would want to "delete" this particular job in order for me to isolate a current problem.

On SM37, I tried deleting that job yesterday by clicking its checkbox and then Job --> Delete. It was no longer present when I searched for it again choosing all the Job Statuses (Scheduled, Released, Ready, Active, Finished, Canceled).

However, just this morning when I came back at the office, I was surprised to see that the job has actually run again!

Kindly advise me as to how to permanently delete this job. Thank you very much in advance! 😊

Best Regards,

Al

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

6 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2008 at 03:13 AM

    Hello,

    in sm37 --> give the job name (released , scheduled) excute

    select the job -->change (cntl+F11) -->start condition -->

    remove the periodic job option-->delete the job

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2008 at 03:18 AM

    Hi Al,

    Check the job details to know Last changed date, time and the user. So that we can know whether it has been scheduled by somebody else. Also give the job name and variant you were using if it is SAP recommended standard job.

    Regards,

    N.Amarnath

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Amarnath. I checked, and nobody has changed it since I successfully scheduled/released it. I have only "deleted" it on the Job Overview page (with status being "Finished"). As I've told earlier, I was suprise to find that it has successfully run.

      Regards,

      Al

  • author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2008 at 05:32 AM

    Hi Albert,

    I thing somting is wrong done by you otherwise deleted job can not be activate.

    Please check at your end.

    Regards,

    Anil

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 10, 2008 at 08:35 PM

    Hi,

    Please check if any personal setting was done for the Job.Delete the setting as well.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 12, 2008 at 05:25 AM

    Hi,

    Check for the variant if any for the background job.

    1. Delete the scheduled job from SM37 by delete flag

    2. Check for the variant set during the background job.

    Acess that variant with respective code get that variant & delete this variant form that client.

    Hope this will help you in deleting background job from system.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 14, 2008 at 05:58 AM

    Hi Friend

    you just call to SM 37, give the proper information for that job, and then find and select your job, double click on that job, now you will get one screen window in that window you just you find one tab called JobDetails just you click on that tab, again you will get one more window, in that window you will get the Job information in that information you just find PID for this job and note down that id.

    then you call to SM 50 now you just find the PID for that job, now you select PID and Delete that ID,

    then again you go to SM 37 screen, next you select that job go to job overview menu in that menu you just find job captured next in that same job overview menu just select JobDelete option

    now you just refresh that screen, it was deleted.

    now go ahed frend...

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks very much Kondalu. What I did was change the job property (set as non-periodic). It ran for the last time, and it no longer runs afterward. I'll probably do your suggestion when I encounter the problem again.

      I appreciate your help my friend. 😊

      Regards,

      Al

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.