Skip to Content
avatar image
Former Member

SHD0 and VA01 transaction variant: Changes not showing in Test mode

Hi,

I am trying to create a transaction variant using SHD0 for VA01 and VA02 that will grey out the PLTYP field in screens 4301 and 4900.

Everytime I go through the process and exit and save it looks fine, but when I test the variant, the fields are still editable, even though my variant shows them listed as Output Only checked off for the aforementioned screens

I am using the following:

T_Code for variant: VA01

Variant: copy of BUS2032 renamed Z_BUS2032_KPW.

screens to be affected : 4301 and 4900.

I do not want to override the default variant. I am currently in R/3 4.6c.

Any help other than links to the SAP help website (which I have exhausted) would be greatly appreciated.

Thanks,

Kevin Webb

www.innovapost.com

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    Jun 05, 2008 at 03:30 PM

    In transaction VOV8, for your sales order type, assign your variant to variant field (Transaction group)

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Kamesh Yeleswarapu

      Both screen variants are assigned to the new transaction variant.

      They are the only two screen variants currently assigned to the transaction variant.

  • avatar image
    Former Member
    Aug 11, 2008 at 04:03 PM

    For the sales order type, using TCODE VOV8, set 'NO_VARIANT' to Variant field

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Sai P,

      HELP!

      I have a similar situation: VA01 running standard and ZVA01, with a hidden field, once I assigned NO_VARIANT to the Order type ZVPV, it is working as desired. However, one strange thing is happening... when I enter ZVA01 and assign the order type ZVPV (which has NO_VARIANT at VOV8) I enter and the field is hidden this all good, then I go back to the screen were the order type is assigned and then I choose another order type ZTA (which has variant in VOV8 in blank) and the hidden field shows, all good as well. However, when I go back again to the order type screen (without going back to the menu screen) and choose again ZVPV and enter the field is showing. Any idea?

      Regards.

  • avatar image
    Former Member
    Jun 06, 2008 at 06:56 AM

    Hi

    Could u let me know of what all parametrs u selected for PLTYP field when ur defining for variant?

    Thanks

    Sri

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I had a similar problem and only realized that I have not activated the variant. Go to the standard variant tab. There is another sub tab called standard variant. Yo need to activate your variant in all clients.

      Cheers

      Andries

  • avatar image
    Former Member
    Jul 10, 2008 at 04:51 PM

    We have decided to use the user exit and code a restriction based on user master data

    Add comment
    10|10000 characters needed characters exceeded