Skip to Content
Former Member
Jun 05, 2008 at 02:36 PM

ESS time sheet problem


It turns out the reason we can't display our Z custom fields in CATS is because they have the word 'field' in the name and the Class CL_XSS_CAT_PROFILE has a piece of code that bypasses any CATS field with the name 'field' in it. (This seems to be a contradiction in SAP's policy not to mess with custom fields starting with the letter Z.) We have tried renaming the fields using transaction SE11 but we loose the history of CATS data. We also used transaction CMOD and also lost the data. We have also tried changing the code in the Class CL_XSS_CAT_PROFILE but that seems to cause other problems.

I have attached several screen shots. The first one CI_CATSDB.jpg shows the 9 fields in question. The second one, catsdb, shows the ci_catsdb include at the end of catsdb. The third one, PREPARE_FS_TS, shows the SAP code where it is skipping the custom fields for the new time sheet. The fourth one set_fs_wl shows whre the custom fields are being exluded in the new time sheet work list.

We have tried two different options on renaming the fields in ci_catsdb. Both options were successful as far as displaying the time sheet. However, both options also deleted the data. I do not know what either option does to the archived data.

One option was to run SE11 on ci_catsdb and rename the fields. The second option The second way was to have two sessions opened. One running transaction code spro and the other running transaction code cmod.

Under spro

cross-application components -> Time Sheet -> settings for all user interfaces -> Customer-Specific Modifications -> create custom Fields -> make field assignment I would delete the field save it. Then go to the second session (running transaction cmod) rename field, save it activate it. Then go to the first session insert the new field,

Your prompt attention to this issue would be greatly appreciated.

Edited by: babu rao on Jun 5, 2008 4:37 PM