Skip to Content

Cleanup of tables SXMSCLUP & SXMSCLUR

Currently the first table is was over 94 gig and we would like to delete all messages out of it before a certain date. I have tried running the different jobs but havn't been able to get more than 30 gig of messages out of it. How can I clean them up?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 04, 2008 at 02:56 PM


    You should run report "RSXMB_DEL_CLUST_TABLE" to delete entries from this two tables.

    Yo need activate Archiving and Deletion Jobs.

    To find the relevant jobs, call transaction SXMB_ADM and choose: Administration > Schedule Archiving Jobs

    If you using BPM see this notes:

    SAP Note 836092: Archiving/deleting work items in the XI

    SAP Note 874708: BPE HT: Deleting message persistence data in SWFRXI*


    How to clean or delete

    Messages that have been processed correctly are deleted by default. You must archive all messages that are not to be deleted.

    For more info :

    Refer this forum link this will help you


    Please reward points



    Edited by: Khimavath Vikranth on Jun 4, 2008 4:59 PM

    Edited by: Khimavath Vikranth on Jun 4, 2008 5:00 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 04, 2008 at 02:59 PM


    Instead of deleting them try archiving the data.

    Check these forum replies.





    Edited by: Vijaya Lakshmi Palla on Jun 4, 2008 11:00 AM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 19, 2008 at 02:34 PM

    Hi David,

    Do you need the data for historical reasons? Is there a reason you want to archive the data? For our env we have a start point and an end point (for the messages) both of which can determine the success or failure of the messages in question, that is why we didn't have a need to archive any data. Any statistics you really need can be found in ST03 and ST06.

    I (during the go-live of XI) had approximately 120GB of data in the SXMSCLUP table and a large chunk in the SXMSCLUR, and attempted to archive the data. First off the directory I specified was filled in a matter of 1 day and the archiving didn't complete because of it. The worst part was that once we hit the 100% mark we had to do a restore, because we had some internal database issue and couldn't add more space post high water mark hit!

    What we ended up doing was deleting the data that was 1 day old (you can't delete anything less then 24 hours old.

    First what we did (if you are not keeping any data, although you still could do this):

    in transaction SXMB_ADMIN

    Check the "Persistence Layer Analysis" entry and see what the systems estimated level is at (for us we were well in the 85 - 90% area.

    1. Define Interface for Archiving and Retention Periods (we removed all entries defined to be archived).

    2. Define Interface for Archiving and Retention Periods: -> Retention Periods

    Basically I entered "1" for all the entries except Hisotry Entried for Deleted XML MEssages: 10

    3. (if you didn't already) Schedule Delete Jobs and have it run as soon as possible (maybe go to the release job and activate them).

    Another area I ran to clear out some old data in the database from a URL is: http://<sid>ms.<FQDN>:5<System number>00/MessagingSystem/archiving/reorgdb.jsp

    Also check if you have logging turned on in the "Integration Engine Configuration" portion: Click :"Specific Configuration" button and check the Category "RUNTIME" and the parameters for logging. What SAP tells me is that the amount of logging you turn on is the cause for some of the table spaces to get a little large because of the message mapping and conversion. Last check I believe it was 10 copies of 1 message in SXMSCLUP, but that was the word of a DBA (which I am not).

    Sorry got long winded and kept remembering what we did 2 years ago when we hit this problem.

    Good Luck

    Rocco Espina

    Add comment
    10|10000 characters needed characters exceeded