Skip to Content
0

Bad certificate request format when using STRUST

Oct 25, 2016 at 08:54 AM

121

avatar image

Hi Community,

this is my first Q in the new SCN. I hope this is the correct location, i am a bit lost and very sad about the changes...

Anyone ever had issues when creating certificate requests out of TC STRUST?

I tried to create a request and the base64 encoded output contains line breaks. even if i save as a file, it is defect and i got to fix this manually. I am using the CommonCryptoLib 8.5.4 for SNC/SSF/SSL and never faced that issue before. Doing the same using CLI with: sapgenpse gen_pse -p SAPSNCS.pse -onlyreq -r SNCreq.p10 works fine.

Any ideas?

Regards,

Carsten

1.jpg (757.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
avatar image
Former Member
Oct 25, 2016 at 12:53 PM
2

Hello Carsten,
this is a known already solved ABAP error. The solution for it is SAP note 2036786.


Best regards,
Uwe

Share
10 |10000 characters needed characters left characters exceeded
Kaushik Debnath Oct 25, 2016 at 09:07 AM
-2

I would request you to copy the Recent Certificate either from your saprouter or you copy from your Service Market & then paste in a notepad & save & then try uploading. In general, The certificate ending would be like the below

That means after the ==, the End Certificate remains in the next line.

Also check-out if everything is correct according to the below,

http://help.sap.com/saphelp_nw70/helpdata/en/16/1bb23bdb0d0156e10000000a11402f/content.htm

https://archive.sap.com/discussions/thread/294859

Thanks,

Kaushik


gg.jpg (26.2 kB)
Share
10 |10000 characters needed characters left characters exceeded