Skip to Content
0

ios11 SMP registration error 516

Jan 29 at 06:36 PM

60

avatar image
Former Member

We are experiencing the following error when we try to register ios11 devices to our SMP environment 3.0.13 using a custom SAP developed application.

ERROR=fail in SUPApplication--registerApplication: SUPApplicationRuntimeException:error @ registerApplication 516 SUPApplicationError_REGISTRATION_Resetting Communications

Devices that are currently registered can upgrade to ios11 and seem unaffected. However, when a new ios11 device tries to register, or when a registered ios11 device becomes unregistered and then tries to re-register, we receive this error 516.

We have bypassed the relay server and still receive the same error. ios10 devices work and register normally.

We have referred to kbase article 2545376 - "Which version of SAP Mobile Platform SDK supports iOS 11". We had the SAP Development Team re-compile our app with a new version .ipa file. We installed this on an ios11 device and still receive the same 516 error.

Has anyone had to resolve this issue before?

Do you know if in addition to the .ipa file needing re-compiled, do the SMP MBO's (.jar file) need re-compiled also with the latest SDK?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Feb 19 at 12:45 PM
0

For us, this issue was solved by upgrading the iOS libraries to at least 3.0 SP15 PL08

Share
10 |10000 characters needed characters left characters exceeded