Skip to Content
0

Smartforms error uploading

Jan 30 at 09:40 AM

112

avatar image

Hi guys.

I'm trying to upload a smartforms form QAS system to DEV system and I get an error.

I tried a few things before:

In transaction SE73 -> Printer Fonts -> 'Show available fonts' , you can check what true type fonts are uploaded in a system. - done
RSTXDELL - done
you should ensure that you use the same device type to create the spool or PDF in both systems. - done

The error I get is:

Category               ABAP Programming Error
Runtime Errors         OBJECTS_OBJREF_NOT_ASSIGNED
ABAP Program           SAPLSTXB
Application Component  BC-SRV-SSF
Date and Time          30.01.2018 10:28:58
Short text
     Access via 'NULL' object reference not possible.
Source Code Extract


Line  SourceCde


 1491 *   FRONTEND_PROGRAM                  =
 1492   EXCEPTIONS
 1493 *   OBJECT_NOT_FOUND                  = 1
 1494 *   RFC_ERROR                         = 2
 1495 *   NO_PROFIL_PARAMETER               = 3
 1496 *   IMPORT_PARAMETER_IS_INVALID       = 4
 1497     OTHERS                            = 5
 1498             .
 1499   if sy-subrc <> 0.
 1500     message id sy-msgid type sy-msgty number sy-msgno
 1501             with sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4.
 1502   endif.
 1503
 1504 ENDFORM.                               " show_formpainter_help
 1505 *&---------------------------------------------------------------------*
 1506 *&      Form  SFP_PAGE_START
 1507 *&---------------------------------------------------------------------*
 1508 form sfp_page_test changing p_proceed    type tdbool
 1509                             p_windowname type tdobjname.
 1510
 1511   data: l_page          type ref to cl_ssf_fb_page,
 1512         l_node          type ref to cl_ssf_fb_node,
 1513         l_window        type ref to cl_ssf_fb_window,
 1514         l_pagenode      type ref to cl_ssf_fb_node.
 1515
 1516   p_proceed = true.
 1517
 1518   read table g_nodes index g_selected_node into wa_g_nodes.
 1519   perform get_actual_page using    wa_g_nodes-id
 1520                           changing l_pagenode.
>>>>>   l_page ?= l_pagenode->obj.
 1522

From my debugging I found out that when uploading the file, the class :CL_SSF_FB_NODE Method XML_UPLOAD doesn't detect the 3 pages that my form has. None of them.

Other things I tried:

1. I tried uploading different forms that work in both systems, I get the same error.

2. I have the same system packages.

3. I searched SNOTES regarding this, no result.

4. Tried deleting "Address" forms from the XML (read there where some issues with it)

Nothing helped.

I need help, it's urgent.

Regards,

Marius

10 |10000 characters needed characters left characters exceeded

Are you trying to download/upload a Smartform or a SAPScript? Normally I'd just use upload download. The type is .XML.

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Jelena Perfiljeva
Jan 31 at 09:31 PM
1

I do the same as Michelle mentioned in the comment and never had any issues... When does the error occur exactly? When you're trying to upload the form? That's just SAP standard and SAP Support would need to be contacted with any issues.

Not sure why you're doing this but if this form ever existed in DEV and just got messed up for any reason then you should be able to restore it by re-importing the previous (released) transport that contains the form. Be careful though if there are any other objects in the transport, will need to check their version history.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Jelena,

The system was configured in such a way that the request goes directly to the other system. Only by forwarding the request from Q system to Dev system I could re import the request. Unfortunately not always the Developer has the access to STMS transactions, ergo "Export/Import" is the only way.

That being said, it was the only solution we could find at the moment and for that client.

That being said :))) on a different system of another client I get the same short dump with a different SMARTFORM. And I couldn't find the issue, the reason why I deg the short dump.

So you can't find any other solution but to put a SAP message ?

Regads,

Marius

0

If transport is not an option then yes, I'm afraid reaching to SAP Support is the only way here, sorry.

0
Hedvig Rohonyi
Feb 22 at 04:31 PM
0

Hi Marius,

You wrote that you get the same dump with other forms also, so I suppose the xml file is correct. Could you please check your settings via Smartforms -> Utilities -> Settings. Did you changed here something : page format etc... With other user you get the same dump?

Best regards,

Hedvig

Share
10 |10000 characters needed characters left characters exceeded