Skip to Content

XSA Access to Remote Classic Schema

Hi,

I am new to XSA and trying to access a remote classic schema. For this I am basically following Thomas Jung in the openSAP course and the instructions given in the hands on excercises https://open.sap.com/courses/hana6/items/5axhluGf3iferf1bBWsyKg.

I created a user provided service, which seems to be ok (see screen shots). However when trying to build a hdbgrants or hdbview File refering to the synonym then there are error messages indicating missing user <schemaname>#OO and missing schema <schemaname>#DI (my schema is called “GBIMASTER” (see screenshots).

I know these are names of technical user and schemas which belong to a “normal” XSA database container. So my suspicion is that these should be created for the remote classic schema when creating the user provided service.

My questions: Is this suspicion correct? How can I check if my user provided service is defined correct?

I am using HXE 20 SPS02 on GCP.

Thanks for your answers

Klaus

useroomissing.png (18.6 kB)
cups01.png (12.4 kB)
cups02.png (22.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Feb 16 at 03:58 AM

    The definition of the db module in the yaml file is missing the requirement to the hdi-container (it only references the user-provided service) and I'm not sure if the cross_schema_gbimaster is cut form the picture, but it may also be missing the service-name parameter (where the value is CROSS_SCHEMA_GBIMASTER according to your xs cups command). Once you add the two requirements to the database module (hdi-db and CROSS_SCHEMA_GBIMASTER), you will need to add TARGET_CONTAINER or you'll get a build error.

    There is an example of this here (except for steps 4 to 6, which I will spin into another tutorial when I have the chance): https://www.sap.com/developer/tutorials/xsa-create-user-provided-anonymous-service.html

    Also, make sure that you do have role called GBIMASTER::external_access_g. I also advise against using namespaces.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 02 at 07:02 AM
    -1

    The system did not accept the third picture in the other reply (for whatever reason). So here it is

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 31 at 03:15 AM

    Hi, Klaus,

    It looks like you are using port 39015 and should be 39013 for that version on GCP and the development space pointing at the SYSTEMDB, which could explain the error "invalid schema name" . As for your assumptions, I'm not sure I understand them correctly. Those users are for HDI containers, you will not see them automatically generated for your plain/classic schema (that's what the user-provided service is for).

    Cheers,

    Lucia.

    Add comment
    10|10000 characters needed characters exceeded