Skip to Content
0
Former Member
Jun 02, 2008 at 09:35 AM

Problem with database table (nametab) runtime object doesn't exists

255 Views

Hi all !

Let mi quickly describe this problem.

All the screenshots and excel sheet are in [luxcar.com.pl/tomek/attachment.zip] - no viruses inside - I Promise !! 😉

So problem is:

When I imported our package I got the problem with TWC table. Now, situation looks like this. When I import this table (I prepared the transport) to customers dev system (have SAP_ALL there), everything goes well u2013 no errors. When I run our solution, it crashes on /../TWC and says it doesnu2019t exist. When I access se80 and display /.../TWC properties, everything looks ok (see twc1.gif) u2013 system says that itu2019s active but doesnu2019t exist in database. Ok, I run database utility and press u201CCreate in databaseu201D . This ends up with error message (see twc2.gif). Itu2019s something about missing runtime object (nametab). When I come back to SE80 and press u201CActivateu201D , activation finishes with error log (see attached XLS file) and table turns into u201CPartly activeu201D (see twc3.gif).

We have another table /.../TWCV to store versions - it has EXACTLY the same structure as TWC but in opposite to TWC - there is no problem with transports, creation and activation. (It means - table structure is not a problem itself).

I tried recreating this table manually u2013 from the scratch. The same things happened. I thought it was something wrong with TADIR u2013 I checked and everything was ok there.

Can you help me?

Thank you in advance.