Skip to Content
author's profile photo Former Member
Former Member

Number format not applied

Post Author: pemerle

CA Forum: General

Hello,

First of all, thank you very much for all the contributions available on this forum, it used to help me so many times !!!!

I am actually working on a report with Crystal 9.2.3.884 and I encounter a strange reaction with number formats.

On my number fields, I applied a french format like that 100 000,00. A space for thousand separator and a comma for decimals.

When I launch this report on local, the result is good but when the report is generated on the server all numbers are formatted in US format (like 100,000.00). I think the report uses the regional settings of the machine it's generated from.

Does someone had the same problem and is there any solution to really force the number format on the report ?

A uge thank to you in advance,

Cordialy,

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

8 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 07:54 AM

    Post Author: amr_foci

    CA Forum: General

    i've the same thing with WebI,, no one could help??

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 11:17 AM

    Post Author: pemerle

    CA Forum: General

    I did some tests today switching regional settings from English to French and then from French to English. Unfortunatly it didn't changed anything...

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 11:30 AM

    Post Author: amr_foci

    CA Forum: General

    hahaha, i did the same too , at the server side and at my client side too,, and nothing new

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 01:50 PM
    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 02:29 PM

    Post Author: pemerle

    CA Forum: General

    I've just found a way to solve this problem.

    Do not drag directly your field from the source to the report but insert an empty text object and put in your number field. Apply the format on your number field inside the text object and you will see that your field format works now.

    Please let me know if it works well for you too.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 01, 2008 at 01:24 PM

    Post Author: AndersG

    CA Forum: General

    Great! Who would have thought of that? It does work, but the downside is that I have hundreds of reports that I have to go through... 😔

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 01, 2008 at 07:17 PM

    Post Author: pvierheilig

    CA Forum: General

    While you'll still have to go through each report, this may avoid changing each object:

    File -> Options -> Fields -> Number.

    Chances are you have removed the option of 'System Default' by changing the formats on individual objects. You have two choices:

    Reset to 'System Default' and set each machine to the appropriate regional/locale settings, or change the default format for the number object specifically in this window, which will apply to all number objects. I do not recall if it takes effect immediately or not, so you may have to close the report, after saving it, and open it again.

    Another consideration will be any conditional formatting you may have applied that will orveride these settings.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 05, 2008 at 06:22 PM

    Post Author: AndersG

    CA Forum: General

    OK. Thanks. I will try.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.