Skip to Content
Former Member
Jul 23, 2007 at 04:05 AM

Problem with Save data with report


Post Author: ramprosoft

CA Forum: General


I am new to CR and using Crystal Reports XI with SQL Server 2000.

I'm not able to remove the saved data in a report. I have played around different options, but unfortunately I'm not able to remove the data. I have checked variouse places in web above this issue not able to find a solution, so decided to open a new post. The problem is :

I have created a simple report and saved with-out data (1st version) the file size was 16KB. After few changes I have saved the same report with Data, the file size become 1065 KB. Its perfect and I can view the report in Report Viewer. Great Stuff!. Now the Testing completed, I would like to move this report to production environment, I notice that I'm unable to remove the data. I have played around various tricks like below, but it didnt work well.

Trick 1:

Uncheck: File->Options->Reporting (tab)->Save Data With Report.

Check: File -> Options -> Reporting (tab)->Discard Saved data on Open,

Uncheck: file-> Report Options -> Save Data With Report.

File -> Save Data with Report (Not selected)

Opened the report and try "save" and also tried "save as", still the size is 1065.

Trick 2:

I enabled all "Save Data with report" feature. Deleted all the rows in the table related to the query, previewed the report and Saved the report with "Save Data with report" featuer. But now, the funny part happen, the file size increased to 1070kb, instead of reducing. Worst Stuff!!!

Trick 3:

Updated the latest version of Patch and tried above tricks, still i'm not able to remove the data.

Appreciate, if you could help me to fix the problem.

thanks in advance