Skip to Content
-2

Me11 screen 0105 error in BDC

Jan 31 at 07:53 AM

60

avatar image
Former Member

Hi all,

I have a requirement which could create info records .(Tcode ME11) . I am using a custom

rm06ibi0 program which creates a bdc for the same. But the bdc fails on screen 0105 for me11 saying no batch input No batch input data for dynpro SAPMM06I 0105. I tried skipping the screen by if condition, but still same error appears . Bdc works if done thourgh shdb .

Please help me, how to handle this situation.

10 |10000 characters needed characters left characters exceeded

Have you tried running the BDC in A? Then look at the screen to see what is happening? I'm guessing it might be asking for a certain field to be filled. Pure guess.

0
Former Member

Hi Former Member ,

yes i tried processing the bdc in A mode.It runs without error when i record it and process through SHDB. The issue is when I process it through the custom rm06ibi0 program. When I press enter on screen 0105 of program SAPMM06I it gets processed. I tried adding ok-code /00 in the bdc program but no luck.

0
Former Member

Hi Former Member,

I read your question(BDC error in purchase info record creation through rm06ibi0) and I guess mine is a similar one .

Could you please tell me what changes did you do in the custom program?

0

You are beating around the bush.

Nobody can know what your custom rm06ibi0 is doing, where you made it custom and why.

You should show your coding where you supplied the fields with a value for this screen. You should show a screenshot from SM35 dynpro tab with field list to enable others to verify and compare it eventually with their batch inputs for info records. The best help to help yourself is to give as much input here as you can.

In those past 4 days since you asked your question you could also have put a stapler onto your keyboard as suggested in the other discussion https://archive.sap.com/discussions/thread/3469243

0
* Please Login or Register to Answer, Follow or Comment.

0 Answers