Skip to Content
author's profile photo Former Member
Former Member

Selection Problem

Post Author: gary

CA Forum: Formula

I have a report that was running fine but decided we needed to add another selection restraint. The field, called InvoiceType has four possible values, "ADV", "DEP", "MIS" and "SHP". The new selection constraint was to include only "MIS" and "SHP". I added a constraint to select "MIS" and "SHP" and ran the report. It looked like it was running but sat there for a considerable time with the hourglass showing. Finally it gave the "Program is not responding" error. I tried several things included rebooting my computer and calling the headquarters site to see if there was anything going on with the server that was causing my query to time out. Nothing worked until I changed the selection criteria to exclude "ADV" and "DEP" instead of including "MIS" and "SHP". This seems a bit bizarre. I'm wondering if anyone else has had anything like this happen and, if so, did you find any other way to deal with it. I would much rather have a positive selection in my queries than a negative selection. To me this makes it easier to locate the problem in case another data element gets added and starts being included on the report by default.

I am using CR XI R2 over the Progress database. I am remote from the Progress server (It's in Illinois, I am in California).

Thanks for any feedback.

Gary

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Sep 04, 2007 at 07:30 PM

    Post Author: V361

    CA Forum: Formula

    Without seeing the select statement, I am just guessing. You stated

    The field, called InvoiceType has four possible values, "ADV", "DEP", "MIS" and "SHP". The new selection constraint was to include only "MIS" and "SHP".

    did you have this in ["MIS", "SHP"]

    and where was it in the Select (sometimes that is important as well.)

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.