Skip to Content
author's profile photo Former Member
Former Member

LOV sorting in InfoView

Post Author: BO_newbie

CA Forum: WebIntelligence Reporting

We have this LOV for fiscal month and we are overriding the BO generated SQL with this query :

select trim(month_name) from (select distinct month_name, month_in_fis_year from dwtd_date where month_name is not null order by MONTH_IN_FIS_YEAR )

This is working in Desktop Intelligence and it is showing like this :

Wand it is showing like this

April

May

June

July

August

September

October

November

December

January

February

But when viewing the report in InfoView the prompt is sorting in alphabetcal order.

We already exported the lov along with the universe but still it is not showing the correct order. It is working properly in Desktop Intelligence.

Is it a limitation in WebI/Infoview or do we need to configure something. Please let us know

TIA

Add a comment
10|10000 characters needed characters exceeded

Related questions

7 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 10:45 AM

    Post Author: amr_foci

    CA Forum: WebIntelligence Reporting

    you can customize your LOV sort as you want at the universe level, right click the Dimenstion - "Objects properties" - "Properties" Tab - "Edit" Button - choose the Column you want want to sort by - click "Sort" icon at the bar - and you can customize the sort from "Manage Sort" icon

    good luck

    Amr

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 10:54 AM

    Post Author: BO_newbie

    CA Forum: WebIntelligence Reporting

    Thanks Amr but we are customizing the sort in the universe level but it is not reflecting in WebI

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 11:00 AM

    Post Author: amr_foci

    CA Forum: WebIntelligence Reporting

    i had the same before,, but after some tries it worked

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 11:03 AM

    Post Author: BO_newbie

    CA Forum: WebIntelligence Reporting

    But we are trying for 2 weeks already. There must be a reason why its coming this way

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 11:16 AM

    Post Author: amr_foci

    CA Forum: WebIntelligence Reporting

    actually i dont know why does this happen,, i had the same thing before , when i edit the LOV settings and export,, and i got no reflection in the WebI,

    but for 2 times i imported the universe editted it once again , exported it again, and it works fine

    wat version and SP of BO u r using?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 11:20 AM

    Post Author: BO_newbie

    CA Forum: WebIntelligence Reporting

    we are using BO XIR2, not sure about SP

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2008 at 11:20 AM

    Post Author: BO_newbie

    CA Forum: WebIntelligence Reporting

    we are using BO XIR2, not sure about SP

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.