Skip to Content
author's profile photo Former Member
Former Member

URGENT! Report Not Accessible through Infoview

Post Author: hd1

CA Forum: Crystal Reports

Help! I have a report that is not accessible through the infoview. I can access the report on my local machine through Crystal Reports, but once I save it to the Enterprise folder, and view try to view it through infoview I can't. It says:

The database logon information for this report is either incomplete or incorrect.

Unable to retrieve Object. The database logon information for this report is either incomplete or incorrect.

I know the problem is my login parameters but I don't know to fix them. When I am in Crystal Reports I try to change the datasource location but they will not update correctly. This is an Access Database that sites on our webserver. I am using an ODBC (RDO) connection. When I look at the properties of the current connection they are wrong. I need to change them, so I go to create new connection and enter in my new login parameters but nothing changes. Is there a way to delete the current connection and start with a fresh one? I hope I can do this without removing them from the report but even then those choices are greyed out.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2007 at 11:25 PM

    Post Author: yangster

    CA Forum: Crystal Reports

    you need to set the db login/password within the CMCthe infoview only allows you to view/run the report but the CMC is where you manage the reports that are published to the system

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2007 at 11:37 PM

    Post Author: hd1

    CA Forum: Crystal Reports

    If you mean go into the Central Management Console, select my report---> Process -


    > Database and set my login parameters there, I have tried that also. That still didn't allow me to login. I did find out how to create my new connections, I exited out of Crystal Reports editor and when I restarted the program I was able to create a new connection to the Access Databases, only this time I didn't set a username or password, I just chose my connection and hit finish. I ran the report in the Crystal Reports editor and it worked fine. When I saved it to the server and tried to run it, it still prompted my for a password.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2007 at 11:55 PM

    Post Author: yangster

    CA Forum: Crystal Reports

    hrmm didn't know you were using an access dbis this db located on a shared drive, your local drive or somewhere else?if your server can't find the access db then that's going to cause it to look for it each time its run

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2007 at 11:58 PM

    Post Author: hd1

    CA Forum: Crystal Reports

    It's on a share drive. I have about 3 Access Database tables in the report. All of the Access Databases are in the same location. My Crystal server is mapped to the drive. I have a ODBC connection from the Crystal server to these files, is there something I need to do in CMC?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.