Skip to Content
0

Installation of new Afaria Server using Database of other Afaria Server

Jan 27 at 06:53 PM

74

avatar image

Hello All,

We have an Single Standalone server of Afaria (old) which is connected to SqlAnywhere Database. Both are installed in Virtual Machine. Now we are trying to setup a new Single standalone server of Afaria (New) in different installing both Afaria and SqlAnywhere Databse in a new Virtual Machine.

Currently , we have copied the backup file of old Database and saved in New database VM and unloaded the file in New DB after creating a Database of same name and Configuration. But when we try to install new Afaria using New DB it getting installed as Farm Server instead of New as we require. The reason is the Old Afaria Server details is already present in DB as Master.

Please advise how we can handle this situation. Do let me know if required any more clarification on my Query.

Thanks

Alok Kumar

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Aziz Dhrif
Jan 29 at 09:25 PM
0

Hi Alok,

Most likely in your existing db there is a Master server already listed in A_Server table. I highly recommend following our best practice moving Afaria to another server. Check the following KBA for more details:

https://launchpad.support.sap.com/#/notes/1990189

I hope this helps.

Aziz

Share
10 |10000 characters needed characters left characters exceeded
Atsushi Asano
Jan 29 at 12:50 AM
0

Hi Alok,

I have a question.
Does new database start normally? You can confirm it by dblocate command.

Server Enumeration utility (dblocate)

When new database starts, can you choose a server name with "SQL Anywhere Server Setup" screen? (4. Apply SP17(Reconfigure Afaria server))
Please refer to following KBA for the details.

2363629 - About database(SQL Anywhere) support of Afaria 7 SP17

Thanks,
Atsushi

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hello Asano,

Thanks for your Response.

I have checked using the dblocate command the database are getting listed. Also while DB start I am able to select the Server name.

I have referred the Note provided by you .

Please do let me know if you have any further query

Thanks,

Alok Kumar

0

Atsushi Asano Is there anything if you can suggest, as its not working for me.

0

Hi Alok,

You will confirm the document which Aziz showed.

Disaster Recovery in SAP Afaria 7
https://wiki.scn.sap.com/wiki/display/SAPMOB/Disaster+Recovery+in+SAP+Afaria+7

This document has the following explanation.
> Farm Server
> 2. Prior to reinstallation, remove the row correlating to the farm server system from the A_SERVER table in the Afaria database.

Please refer to following KBA for the details.
1925426 - How to remove an Afaria farm server

Thanks,
Atsushi

0
Alok Kumar Jan 31 at 11:37 AM
0

Aziz Dhrif Atsushi Asano Thanks both for help.

Database was successfully Restored. A_Server table was not able to truncate table as it had referrence to other table, so I have tried to delete the Data from A_Server table and it has worked for me

Thanks again both.

Share
10 |10000 characters needed characters left characters exceeded