Skip to Content
avatar image
Former Member

eSocial - Status Processando em Lote na Produção

Boa tarde, Pessoal!

Estamos realizando o envio do evento S-1000 para o Governo. Na primeira tentativa ocorreu erro de comunicação com o Governo, tivemos que reconfigurar a comunicação. A comunicação agora está estabelecida, mas não conseguimos alterar o status do evento mais, só fica com o status Processando em Lote, não conseguimos mais colocar o status como Pronto para Enviar. Quando tentamos enviar o evento novamente na transação PC00_M37_EFD_MONITOR ocorre uma mensagem que o evento não está com o status correto para envio.

Indo na transação PC00_M37_EFD_BTCMON e tentando re-gerar o lote e enviar novamente para o governo, não consigo fazer isso, pois ocorre a mensagem que o evento está com status incorreto para envio. Por favor, aconteceu com alguém essa situação? Sabem como alterar o status do evento na produção, no ambiente de QA conseguimos na transação PC00_M37_EFD_VIEWER alterar o status, mas na produção essa transação não permite alterar o status do evento.

Por favor, sabem como solucionar o problema?

Desde já agradeço.

Cristine Trindade

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Feb 21 at 01:46 PM

    Olá Cristine, tudo bem?

    Estou com o mesmo problema, você conseguiu resolver?

    Obrigado,

    Yutaka.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 22 at 02:44 PM

    Olá, tivemos um problema semelhante.

    Ao executarmos a transação que gera o lote, tivemos um dump. O lote ficou com status "Criado" e os eventos com "processado em lote".

    A orientação foi a aplicação de notas:

    2586295 - eSocial - Corrections - Phase 2018/02 part 1

    2589483 - eSocial - Overview of phase 2018/02

    2599234 - eSocial - Overview - Phase 2018/03

    Espero que ajude!

    Ana Carolina Matoso

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 23 at 11:46 PM

    Olá, Realmente o PC00_M37_EFD_VIEWER só altera em qas , pois ele verifica a role do ambiente (SCC4) se for produção o botão não aparece.

    Carlos A. Hoepers

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 28 at 01:03 PM

    Bom dia a todos!

    Cristine, inicialmente sugiro verificar se a transação PC00_M37_EFD_PSCHED está sendo executada corretamente (para a transmissão dos eventos).

    - Sobre o evento com erro, após corrigir o erro, tente gerar o evento novamente (PC00_M37_EFD_ER_GEN), o sistema irá identificar que já existe um evento S-1000 gerado e irá verificar se houve alguma alteração nos dados do evento, sendo identificada alguma alteração, o evento existente será ajustado e irá retornar para o status "Pronto para verificação" (ou "Pronto para enviar - dependendo das configurações da companhia), feito isso, execute a transação PC00_M37_EFD_PSCHED e verifique se o evento foi transmitido.

    Sobre a questão dos lotes, tivemos o mesmo problema e chegamos a conclusão que não é correto utilizar a opção "re-gerar lote" pois ele da o erro "Status incorreto para envio", além de criar uma "Sujeira" no seu monitor de lotes, quando corrigimos o evento, conseguimos enviar ele utilizando a opção "Reenviar o mesmo lote", caso não funcione sugiro cancelar o evento:

    - A opção tornar obsoleto - na transação PC00_M37_EFD_VIEWER - é liberada apenas para ambientes não produtivos, para ambientes produtivos existe a opção "Cancelar" no monitor de eventos (PC00_M37_EFD_MONITOR), ao utiliza-la o status do evento é alterado para "Manualmente cancelado" e você consegue gerar um novo evento.

    Espero ter ajudado.

    Daniel Nantes

    Add comment
    10|10000 characters needed characters exceeded