Skip to Content

Mobile Native app android logon fail with scp

Jan 25 at 11:56 AM


avatar image

Hi everybody,

I followed this sap tutorial

but I'm unable to login with my scp trial account.

My build.grandle file is the follow:

apply plugin: ''

android {
    compileSdkVersion 26
    defaultConfig {
        applicationId "com.northwind.nwandroid"
        minSdkVersion 19
        targetSdkVersion 26
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner ""
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), ''

dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile ''
    compile ''
    compile ''
    compile ''
    testCompile 'junit:junit:4.12'
    compile project(':MAFLogonUI-3.16.1')
    compile project(':MAFSettingScreen-3.16.1')
    compile project(':MAFUIComponents-3.16.1')
    compile project(':MobilePlace-3.16.1')
    compile files('libs/AfariaSLL-7.00.6169.0.jar')
    compile project(':ClientHubSLL-3.16.1')
    compile project(':ClientLog-3.16.1')
    compile project(':Common-3.16.1')
    compile project(':Connectivity-3.16.1')
    compile project(':CoreServices-3.16.1')
    compile project(':DataVaultLib-3.16.1')
    compile project(':E2ETrace-3.16.1')
    compile project(':HttpConvAuthFlows-3.16.1')
    compile project(':HttpConversation-3.16.1')
    compile project(':MAFLogger-3.16.1')
    compile project(':MAFLogonCore-3.16.1')
    compile project(':ODataAPI-3.16.1')
    compile files('libs/odataoffline.jar')
    compile project(':ODataOnline-3.16.1')
    compile files('libs/perflib-1.2.0.jar')
    compile project(':Request-3.16.1')
    compile files('libs/sap-e2etrace-')
    compile project(':SupportabilityFacade-3.16.1')
    compile project(':XscriptParser-3.16.1')

As you can see I imported the library in aar format because in the sap mobile sdk directory I didn't find the .jars file.
I tried also to extract all the aar files and use the jar files inside of them but I've obtain the same result.

In the simulator I tried to login using chrome and it seems login succesfully....

I've used also my real device and problems still persist.

using adb logger I've found this:
ClientHub: SSO Client not installed on this device

Any suggestions?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers