Skip to Content

Design Studio. Prompt variables selections are not transferred to the filter panel

Hello,

SAP BusinessObjects Design Studio 1.6 SP4 Patch

I have an issue with the prompt. The prompt variables’ selections are not transferred to the application filter panel, only the month dimension, please see below. The merge prompt is enabled. In the prompt settings all the variables are added that should be also displayed in the filter panel . The filter panel data source and target are set and checked.

Can I transfer the prompt variables’ selection by script to the filter panel?

Thank you,

Cristina

1.png (25.5 kB)
2.png (15.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 25 at 01:32 PM

    Hi Cristina,

    As a best practice, prompt variables AND filters on the SAME dimension should not be applied together. Only one method should be used per dimension, with a preference for filters over prompt variables where possible. It is expected that prompt variable values are not transferred to the filter panel because prompt variables are not filters. In your example where Month appears to have been transferred to the filter panel I can only assume that somehow the prompt variable value has also been applied as a filter value on the Month dimension.

    Can you provide a screenshot of the filter panel properties sheet showing the Data Source and Target Data Source? Can you also confirm which data sources in your application contain the Month dimension and the Month prompt variable?

    Regards,

    Mustafa.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Mustafa,

      I solved this issue, by creating a copy of the Data source which I used in the filter panel and the original one I have used as a target and the values have been transferred successfully.

      But I have another issue with displaying the variable value in the prompt, may be you could explain the logic behind of the displayed data.

      I'm using as a data source for the Design Studio application, 2 Bex queries, which have filter restriction applied for 0SALESORG dimension in the queries. This variable is used to be displayed in the prompt. In the application -> Data Source ->Initial View, the variables which are used in the prompt menu, have the following selection checked: Members for filtering -> Only Values with posted data and Members in result -> Only Values with posted data.

      However in the prompt menu, the variable values for 0SALESORG is empty, no posted values are displayed and you need to type in the key manually, please see below:

      pic1.png

      Do you know why could be the reason?

      Thank you and best regards,

      Cristina

      pic1.png (47.6 kB)
  • Jan 24 at 09:42 PM

    Hi Cristina - there are issues with the filters that are fixed in later SP's. See https://launchpad.support.sap.com/#/notes/2376849 - any chance you could patch up to the latest patch (SP05, SP06?)

    Add comment
    10|10000 characters needed characters exceeded