Skip to Content
0
Former Member
May 26, 2008 at 10:21 AM

B2B error. No catalog data is shown.

15 Views

Hi all,

I have configured a B2B application but I have a problem. No data is showing in the application. I can log on alright but no data is showing. If I click Go or to create a new shopping basket I get an error and being forced to log out. In the logs I can see these two errors that looks similar:

A runtime exception occurred on the highest level

EXCEPTION

java.lang.NullPointerException

at com.sap.isa.isacore.action.GenericSearchBaseAction.addRequestedFields(GenericSearchBaseAction.java:525)

at com.sap.isa.isacore.action.GenericSearchBaseAction.buildSelectOptions(GenericSearchBaseAction.java:140)

at com.sap.isa.isacore.action.GenericSearchISAAction.ecomPerform(GenericSearchISAAction.java:65)

at com.sap.isa.isacore.action.EComBaseAction.doPerform(EComBaseAction.java:353)

at com.sap.isa.core.BaseAction.execute(BaseAction.java:211)

at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)

at com.sap.isa.core.RequestProcessor.processActionPerform(RequestProcessor.java:674)

at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)

An exception has occurred: java.lang.NullPointerException

at com.sap.isa.isacore.action.GenericSearchBaseAction.addRequestedFields(GenericSearchBaseAction.java:525)

at com.sap.isa.isacore.action.GenericSearchBaseAction.buildSelectOptions(GenericSearchBaseAction.java:140)

at com.sap.isa.isacore.action.GenericSearchISAAction.ecomPerform(GenericSearchISAAction.java:65)

at com.sap.isa.isacore.action.EComBaseAction.doPerform(EComBaseAction.java:353)

at com.sap.isa.core.BaseAction.execute(BaseAction.java:211)

at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)

at com.sap.isa.core.RequestProcessor.processActionPerform(RequestProcessor.java:674)

at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)

at com.sap.isa.core.RequestProcessor.process(RequestProcessor.java:391)

at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)

Any ideas?

It feels like I don't get the data from the backend correctly?

Regards,

Daniel