Skip to Content
author's profile photo Former Member
Former Member

Problem in automatic import

Hi All,

I have a problem in working with automatic import. I have done settings in MDIS(username & password changes),stopped & started the server, made processing type automatic in Console.

When I place a XML file in the ready folder, the file is being picked but in the log folder iam getting an error saying

The system cannot locate the resource specified. Error processing resource 'file:///F:/usr/sap/SAP MDM 5.5/Server/Distribut...

I am able to do manual import by using the port option without any problems.

Note: My entire installation is in E: only the distribution folder is FTP enabled & placed in F:.

Regards,

Pramod

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 24, 2008 at 11:16 AM

    Hi Parmod,

    Firstly, if u have installed your MDM Server in E: drive, then your Xml file should be placed in E: drive of your respective repository ready folder.

    if you are using FTP server to place this file in ready folder of your respective repository folder, then you have to define the Path in FTP server for your Anonymous user or you can create new user if data is coming from any R/3 to your MDM System.

    E:\Program Files\SAP MDM 5.5\Server\Distributions\IPAddress_MSQL where IP of machine where your MDM Server is Installed.

    Apart from this , Check in MDM console for your define Port Is Remote System and map is correct.

    Also go to your Port

    E:\Program Files\SAP MDM 5.5\Server\Distributions\IP_MSQL\Rep_Name\Inbound\Rem_Sytem\Port_Name.

    Here under log folder, delete your Log file, also check exception folder if you find any xml file delete it also in ImportX, StructuralX etc.In MDM console also check have you mapped your field and Values Properly.

    Start your MDIS , Manually Place the file in ready folder of repository Port Map then check is it transferring to Archive folder sucessfully or not,

    Hope it hepls you,

    Rewards if Useful......

    Mandeep Saini

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Mandeep,

      Thanks for your quick reply.

      I will check the settings in FTP server.

      As of now i am manually pasting the xml file in the distribution folder in the particular repository.

      I am able to succeed by using port option manually.

      is there anyprocedure to do auto import.

      After the file is being picked what is the next process?

      Please helpme out.

      Regards,

      Pramod

  • author's profile photo Former Member
    Former Member
    Posted on May 24, 2008 at 10:15 PM

    What versions of the MDS and MDIS are you running?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Harrison,

      I did not find any versions in MDS & MDIS files.

      I am using MDM 5.5 sp5 buid version 5.5.42.96.win.64.

      My distribution folder is placed in F: made FTP.

      My server, import server & syndication server folder has been placed in E:

      String resource dir specifies this location:String Resource Dir=E:\usr\sap\SAPMDM1.5\IMPORT1\LangStrings\.

      Regards,

      Pramod

  • author's profile photo Former Member
    Former Member
    Posted on May 26, 2008 at 08:10 AM

    Hi Pramod,

    I am not very sure of the exact cause of the problem however I strongly feel that this is due to the difference in the paths of the MDM server installations ie (where your ini files are stored) and your distribution folder path (where your ready folder is placed).

    The error - unable to find resource pointd to this problem.

    I have worked on automatic importing before and tried both manually n automatic with and without FTP and it works fines.

    Try and bring both under one path and one drive.This might solve your problem

    Kindly Reward points if found useful

    Thanks & Regards

    Simona

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Parmod,

      1 .Version mismatching could be one of the cause i would suggest you to install MDM server and other MDM GUI Clients of the same Version.

      2. Only one record is creating instead 10, please check your mapping fields and Values manually by going into MDM Import Manager , During match records, check your default import action that how many records is it showing for create, 1 or 10, what could be the reason you can see over here, also check on what are your matching fields, your matching field should have unique values so that during import it will properly create records into MDM Data manager whether records are already existing or not.

      Hope it will help you,

      Rewards if Useful.....

      Mandeep Saini

  • author's profile photo Former Member
    Former Member
    Posted on Jun 16, 2008 at 09:12 PM

    Hi All,

    The problem got solved as there was no XSL style sheet in the Log folder,the error was misleading us.

    I placed a XSL style sheet from Log folder in the server & the file got opened.

    Regards,

    Pramod

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.