Skip to Content
0

Bulk loading tables in mysql

Jan 24 at 11:20 AM

89

avatar image
Former Member

HI experts,

I have 3 tables with apprx 80K records set to truncate load in staging area.

It takes about 30 mins to load them and as SAP suggested that MYSQL is not supported for bulk loading.

What will be the best approach to load them?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Ravi kiran Pagidi Jan 24 at 04:36 PM
0

what is your source? is it a database table or sap table? and are there any transformations/joins applied between source and target?

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks Ravi for reply.

Both source and target is Mysql V5.

There's a query transform without any aggregation and 1 to 1 mapping with source table as its a staging load.

0

Did you increase array fetch size in source table options and rows per commit in Target table option?

And another way is to do FULL pushdown, if source and target are in different servers, try creating database links and configure same in datastore (linked data stores). and when you see sql query generated by DS should start with INSERT INTO.

0
Former Member

Thanks again Ravi for the reply.

But somehow its showing "select" rather than "Insert into " even if I have direct mapping with output where a simple where clause saying <column> = 0.

Both source and target on same server and database just diffferent schemas.

0

Hello,

try creating aliases in the datastore.. try creating alias for target SCHEMA in source datastore and import target table into source data store. Right click the dataflow properties and check if "use database links" option is checked or not. if not checked please check the option. and also check if source schema has insert grants on the target schema.

0
avatar image
Former Member Jan 29 at 11:36 AM
0

Hi SN,

If you have used MYSQL as a target database then you want to follow below steps to correct the same error:

Step 1: Open your current job and go to data flow.

Step 2: Double click on Target table.

Step 3: Go to Bulk Loader Option -> Unchecked for Bulk Load.

Step 4: Save job and re execute the same.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks Dhanraj but this option is not visible to me,we are using Mysql 5 on AWS

0