Skip to Content
avatar image
Former Member

BR0187E: parameter/option 'control_file_record_keep_time' smaller than 180

Hi All,

This is our infrastructure:

SAP ECC 6

Oracle 10.2

Windows 2003 Server

Legato Networker 7

Since we need to implement an incremental backup strategy. we changed manually our initSID.sap file backup_mode parameter from ALL to FULL in our DEV and QA since that moment the backups crashed immediate (remenber that you need a FULL backup if you want to run IMCREMENTAL backups).

Error:

DEV System:

BR0477I Oracle pfile E:\oracle\MID\102\database\initMID.ora created from spfile E:\oracle\MID\102\database\spfileMID.ora

BR0187E Value '30' of parameter/option 'control_file_record_keep_time' smaller than 180

BR0158E Error reading database profile E:\oracle\MID\102\database\initMID.ora

QA System:

BR0477I Oracle pfile E:\oracle\MIQ\102\database\initMIQ.ora created from spfile E:\oracle\MIQ\102\database\spfileMIQ.ora

BR0187E Value '30' of parameter/option 'control_file_record_keep_time' smaller than 60

BR0158E Error reading database profile E:\oracle\MID\102\database\initMID.ora

We rollback the change in the backup_mode parameter and the backup run without problems, so it appears that we didn't change the backup_mode parameter in the correct way.

What is the correct way to do this?

Best Regards,

Erick ILarraza

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    May 22, 2008 at 03:47 PM

    Hi All, we found the documentation about this file (init<SID>.sap).

    http://help.sap.com/saphelp_erp2004/helpdata/en/c7/c90e6b7cfd44309bd90b2b7a8a89fd/frameset.htm

    We edited this file manually with notepad. I can't understand the error since we only changed the back_mode parameter.

    Best Regards,

    Erick Ilarraza

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 23, 2008 at 01:49 AM

    Hi,

    As a first step to ensure it's not due to bugs, please make sure you are using the latest patch level of Brtools.

    Best regards,

    Warren

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi! we found the solution:

      The value of this parameter may not be smaller than 30

      and not smaller than the value of the init<SID>.sap parameter expir_period.

      So we change the expir_period parameter and the backup works!

      Please refer to the SAP note: 118319 - Param. control_file_record_keep_time not set

      Best Regards,

      Erick ILarraza