Skip to Content
1

Outbound queue not generated after order creation in RRP3

Oct 24, 2016 at 11:24 AM

218

avatar image
Former Member

Hi All,

I have created a planned order from RRP3 transaction in APO system. But the order is not getting transferred to ECC system.

I deactivated the queues and then noticed that the outbound queue in SMQR is not visible after the creation of order. Can you please let me know what could be the issue with outbound queues ?

Do we have any configuration for controlling the transfer of orders ?

Thanks,

Manojkumar K

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Tiago Furlanetto
Oct 24, 2016 at 03:33 PM
0

Hi Manojkumar,

In transaction /SAPAPO/RRPCUST1, make sure setting Transfer to R/3 In-House Production has value Always Create Transfer Events:

-

Additionally, in transaction /SAPAPO/C4, make sure that the entry for user * and/or for your user has value Default for field Recording:

-

Additionally, as described by Tiemin, make sure that an entry exists in transaction /SAPAPO/CP1 for the Publication Type In-House Production for the affected Location-Logical System-Release.

-

Other than that, you may check SMQ2 on ECC side, to check whether there are any planned order queues stuck in sysfail status, as well as execute /SAPAPO/C5 in APO to verify whether change pointers were generated for the PlOrd you created/changed.

-

Regards,
Tiago


Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Tiago,

Thanks for your reply.

I have followed the steps suggested above but still the issue is not resolved. And executing /SAPAPO/C5 i have noticed that there is no entry for change pointers after creation of order. Can you please help me with change pointer related config. steps ?

Thanks,

Manoj

0

Hi Manoj,

If the Publication Type was maintained in /SAPAPO/CP1, the entry in /SAPAPO/C4 has value Default, and in /SAPAPO/RRPCUST1 the setting was made to Always Create Transfer Events, the order should be transferred to ECC immediately upon saving the results at the Product View and change pointers should not be created.

The existing orders which were there before the configuration was made can be pushed to ECC with the Delta Report (/SAPAPO/CCR). For newly created orders, if they were not transferred and the queue is not stuck in SMQ1 (in APO) or SMQ2 (in ECC), please, check whether CCR detects as "Missing in R/3".

Regards,
Tiago

0

If you have debugging rights, you could also set breakpoints at Function Module /SAPAPO/RRP_EVENTS_PUBLISH and at statement RFC, then reproduce the issue. When you save the results, /SAPAPO/RRP_EVENTS_PUBLISH should be called and reach line 31:

-

When that is reached and you press F7, it should stop at the RFC call which sends the order to ECC

1
Tiemin Wang
Oct 24, 2016 at 01:07 PM
0

Hi Manojkumar,

Please make sure that distribution has been defined in //CP1 for type 031 In-House Production and the location.

Best regards/Tiemin

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Tiemin,

I have defined the distribution in //CP1 but even after that the orders are not transferred to ECC system.

And also no outbound queue visible in queue monitor.

Thanks,

Manoj

0