Skip to Content
0

Cannot assemble: "concurrency-lock-denied" followed by "-7 connection to partner broken."

Jan 23 at 08:39 AM

89

avatar image

During transport to our ACC environment, at the assembly tab, after around 10 minutes the assembly fails in the “Repository-export” step with the following exception:

com.sap.cms.tcs.interfaces.exceptions.TCSCommunicationException: communication error: VcmFailure received: Precondition Failed "concurrency-lock-denied"

In the defaultTrace file I see the following message right after the error:

Failed to finalize the request. This exception is not rethrown, but only written into the logs. The causing exception is nested. [EXCEPTION] com.sap.bc.proj.jstartup.fca.FCAException: Cannot get OutBuffer: -7 connection to partner broken.

The first error I tried to resolve by restarting sap.com\tc~dtr~enterpriseapp but to no avail… The second error presumably indicates a timeout, but seems there isn’t a setting for it

Any hints on how to solve this other than turning off all the checks (see image) are highly appreciated!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Szabolcs Renyo
Jan 23 at 03:57 PM
1

Hi Robin,

We had an incident in the past which was solved by the following KBA:
1750758 - DC build in CBS fails

After the changes the AS Java should be restarted.

I hope it will help.

Best regards,
Szabolcs

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Szabolcs & Ervin,

Thanks a million, this seems like the solution we're looking for!

2
Ervin Szolke
Jan 23 at 03:54 PM
2

Hey Robin,

I am not sure what the exact cause of the problem could be at this point, but I found this note that might give ideas https://launchpad.support.sap.com/#/notes/2579836

I know this is a general note that has many references to other note, but perhaps helps you in some way. Or did you check this already?

Cheers,

Ervin

Cc: Milen Dontcheff , Szabolcs Renyo , Zsolt Szunyoghy do you have an idea ?

Share
10 |10000 characters needed characters left characters exceeded