Skip to Content
0

Restore Journals Error - Column () must be specified in journal file

Jan 23 at 02:55 PM

55

avatar image
Former Member

Hi All,

Here is what I have done -

1. Created a journal template and posted 1 journal.

2. Ran export package which generated a .jrn file with 1 header and 2 rows for journal entries.

3. Opened the .jrn file in notepad and saved as txt.

4. Opened the .txt file from excel and made it delimited with comma and saved it as csv.

5. Made some changes and tried running import journal package with this csv as input.

First, it gave an error saying ACCOUNT_GR not found. I found in an other working environment that the header for account dimension is kept as ACCOUNT_GR even though account dim name is account, so I changed to ACCOUNT_GR in my csv

Then, it started giving this error, Column () must be specified in journal file. I am sure I have saved this correctly as csv, Any other thoughts please?

BPC 10.1 on HANA BW 740.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Vadim Kalinin Jan 23 at 03:01 PM
0

3. Post here original jrn file opened in Notepad (screenshot)!

csv can be different :)

For sure you can export jrn and import it again without issues!

Share
10 |10000 characters needed characters left characters exceeded
Vadim Kalinin Jan 23 at 03:35 PM
0

You can test that this original jrn file will be successfully imported!

Just change in Nodepad JRN_ID to 0000000002

Looks like your issues are result of Excel save to csv - may be " are added or ...

P.S. Show the dimension list for the model! And please, use "Insert Image" instead of "Insert File" - hard to read!

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Vadim,

Here is what I did -

1. Ran export and it had 2 records (cr/dr) as I posted one journal. Opened the .jrn file in notepad.

2. Changed the journal id from 1 to 2. Saved the file as .csv file.

3. Ran import and it failed saying dimension ACCOUNT_GR not found.

4. Updated the file and chnged the account dimension name from ACCOUNT to ACCOUNT_GR.

5. Re-ran the import and again the same error - Columns () must be specified in the journal file.

0

Something is damaged in your journal template!

Just for test create a fresh copy of ENVIRONMENTSHELL and create test journal. Export/import and you will see that everything is working!

0
avatar image
Former Member Jan 23 at 03:23 PM
0

Hi Vadim,

Attached screenshots.jrn1.png

jrn2.png


jrn1.png (73.5 kB)
jrn2.png (7.1 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 26 at 06:06 AM
0

Hi Vadim,

The issue was with journal validation BADI. We had a custom code in there which was causing the issue. After we turned off the validation, import was successful. Thanks for your help.

Regards,

Ashish

Show 1 Share
10 |10000 characters needed characters left characters exceeded

May be you are talking about: BADI_UJJ_CALCULATED_AMOUNT?

0