Skip to Content
avatar image
Former Member

Crystal Reports (22) for VS2017 layout problem

We have upgrade our system to Windows 10. Since this upgrade, Crystal Report displays reports incorrectly when a “can grow” field takes up more than one line. All previous sections are fixed height up to and including the Page Header Section 3. Section 3 has a minimum height set. The Data Section 3 is set to Print at Bottom of Page. This appears correct when each field in Section 3 is one line or the report is generated on a Window 7 system. On a Windows system, the title for the bottom of page section is displayed and then the previous section is displayed without any data.

cr-result.png cr-layout.png
cr-result.png (46.7 kB)
cr-layout.png (50.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Feb 06 at 05:34 PM

    We found the cause.

    Detail Section B has a formatting formula that counts the number of rows but does not take into account if the can grow is on, adding one row causes it to suppress.

    He needs to add a formula to the detail section that gets the length and if it exceeds the area width then add 1 to the line counter, something like this:

    // if can grow is enabled then need to count the number of lines added

    if Length ({PartData.Description}) > 75 then LineCount := LineCount + 1;

    Then use that value in the section formatting formula.

    Don

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 22 at 06:02 PM

    Hi Paul,

    Formatting is based on your default printer or the printer it was designed against.

    Check your printer and Page Setup options in CR designer and adjust and see if it helps.

    Don

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Both systems, Windows 10 and Windows 7, have the same default printer. Thanks for the quick response.

  • avatar image
    Former Member
    Jan 23 at 01:37 PM

    I have tried different options under Page Setup, Printer Options and Page Options. The changes have made no difference.

    Add comment
    10|10000 characters needed characters exceeded