Skip to Content
1
Former Member
May 18, 2008 at 01:50 PM

Error in JMS communicatin channel while deleivering to WMQ server

443 Views

How to check whether a node in Adapter engine is having messaging service active?

I am having one of the JMS receiver node having error :

"Message processing failed. Cause: com.sap.aii.af.ra.ms.api.RecoverableException: Connector for ConnectionProfile of channel: JMS_Americas_EDI_Receiveron node: 101565650 having object id: #MSGid# encountered error: MQJMS1016: an internal error has occurred. Please contact your system administrator. Detail: java.lang.NullPointerException in sending to destination queue:///NASB.UPXI.EDI.INBOUND.AQ, the message message: JMS Message class: jms_text JMSType: null JMSDeliveryMode: 2 JMSExpiration: 0 JMSPriority: 4 JMSMessageID: null JMSTimestamp: 0 JMSCorrelationID:3258af50-24e0-11dd-bc98-3c2ac1cacf6e JMSDestination: null JMSReplyTo: null JMSRedelivered: false ReceiverId: ### SenderId:### ISA00 00 124165122352 *08 080 5180935U00401 Another 478 character(s) omitted: javax.jms.JMSException: MQJMS1016: an internal error has occurred. Please contact your system administrator. Detail: java.lang.NullPointerException"

The second Line for same mssg id provides follwing info:

""JMS error occurred while processing message 'MSGIDe'; error mesage: MQJMS1016: an internal error has occurred. Please contact your system administrator. Detail: java.lang.NullPointerException null; error code: MQJMS1016"

Can anyone suggest what can be a fix over this. We have tried restyrting j2ee also but the still persists.

Expect points for sure.

Regards,

Nipun