Skip to Content
0

Validação de campos com acento no XML - NF-e 4.0

Jan 19 at 05:05 PM

1.1k

avatar image
Former Member

Boa tarde,

Estamos emitindo notas no layout 4.0 e estamos com problemas com a Sefaz MT, homologação, onde retorna o erro 402, descobrimos que o erro é referente a acentuação em algumas tags, como bairro por exemplo. Parece que este problema ocorre apenas com a sefaz MT e não com as outras.

Verifiquei no GRC que existe uma tabela /XNFE/XMLVALID que controla a validação dos campos do XML, que inclusive existe um flag para retirar os acentos.

A dúvida é, a parametrização para os campos da 4.0 é entregue via suport package ou é feita na mão pelo consultor? Pois nesse caso específico, acredito que teremos que flegar os campos para retiras os acentos.

Alguém saberia me informar?

Obrigado.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

11 Answers

Renan Correa Jan 20 at 11:25 AM
0

Oi Fernando,

Essa tabela é entregue pela própria SAP e não configurada manualmente pelo consultor. Você pode flegar as validações para campos que você precisa e em geral irá funcionar bem, mas na próxima atualização de SP isso será sobrescrito pelo standard da SAP e você precisará alterar novamente no cutover do SP.

Sempre recomendo reportar esses casos para a SAP no componente SLL-NFE para que eles verifiquem a possibilidade de ajustar o conteúodo standard, evitando dores de cabeça futuras.

Eu tive problema com caracteres de controle na tag infcpl, ajustei direto na tabela e reportei para a SAP, estou esperando retorno da equipe de desenvolvimento se eles incluirão no standard essa alteração.

att,

Renan Correa

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Oi Renan, obrigado pelo retorno. Eu abri chamado na SAP questionando sobre isso, o retorno que tive foi que essa tabela poderia ser alterada conforme nossa necessidade, só que em um eventual upgrade do GRC as alterações seriam sobrescritas. Estou montando uma documentação com evidências de testes pois, como o problema ocorre apenas com a SEFAZ de MT, acredito que a SAP deva interceder e analisar melhor o problema.

0
Rodrigo Menezes Feb 28 at 01:58 PM
0

Fernando, abri um post também reportando o mesmo problema:

https://blogs.sap.com/2017/11/15/support-package-28-do-sap-nfe-10.0-mudancas-em-ct-emdf-enf-e/

Estamos com chamado aberto na SAP sobre isso e qualquer novidade, compartilho com vocês.

Abraço,

Share
10 |10000 characters needed characters left characters exceeded
Rodrigo Menezes Mar 06 at 04:52 PM
0

Boa tarde,

A SAP acabou de lançar a nota abaixo com relação a este problema.

2613668 - Rejection 225 due to special character NFe 4.0

Abraço,

Rodrigo Menezes

Share
10 |10000 characters needed characters left characters exceeded
marcos mendes Apr 02 at 05:24 PM
0

Ola pessoal,

Algum de vocês já tiveram o erro em anexo?

Fiz a configuração no GRC (/xnfe/xmlvalid) começou a gerar esse erro. (cenário SD)

Para MM mesmo com essa configuração, continuo tendo erro na validação do XML (erro 225). (Tag InfCPL).


dkjyt.png (3.0 kB)
lgkut.png (3.2 kB)
g8llh.png (4.1 kB)
Share
10 |10000 characters needed characters left characters exceeded
Rodrigo Menezes Apr 03 at 05:28 PM
0

Olá Marcos,

Eu comparei e igualei os registros da 4.00 com a 3.10 na /NFE/XMLVALID e não tivemos mais problemas.

Rodrigo

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Rodrigo, tudo bem?
A minha pergunta a você, acabou saindo embaixo do comentário do post do Fernando.
Por favor, se puder verificar, agradeço a sua ajuda!

Att.,

Vanessa Sutil

0
avatar image
Former Member Apr 09 at 11:03 PM
0

Boa tarde,

Estou usando a tabela /XNFE/XMLVALID para eliminar alguns caracteres especiais e encontrei dois problemas:

1 - Campo: INFCPL - Inclui alguns caracteres especiais no campo " Eli. caract não permitidos" e excluiu os espaços entre as palavras. Configurei conforme a nota 2613668.

2 - Campo: NATOP - Tentei usar marcar o campo "S/espaços branco" para eliminar um espaço em branco na frente da descrição da natureza da operação e não funcionou. Espaço só foi eliminado quando era preenchido no campo " Eli. caract não permitidos".

Alguém passou por isso?

Obrigada.



Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Olá Gabriela,

Estamos com o mesmo problema, o texto fica todo concatenado, mesmo marcando e desmarcando a opção "espaço em branco".

Se obteve algum retorno por outros caminhos, me avise!

Obrigada!

Vanessa Sutil

SAP SD Consultant

0
avatar image
Former Member May 07 at 02:17 PM
0

Olá Rodrigo, tudo bem?
Obrigada pelo post, isso está nos ajudando e muito. Por favor, será que poderia me ajudar a esclarecer só "algumas dúvidas"?

Estamos com este problema no ambiente produtivo, verifiquei que são apenas para as tags "infAdi e InfCpl" que identificam os caracteres especiais devido ao texto inserido.
Minha dúvida é o seguinte, você ajustou aplicando a nota mencionada, no qual a mesma orienta o ajuste para eliminar o caracter especiais, mesmo deixando "default" ou inserindo quais "não deveriam ser permitidos", certo?
Nos testes evidenciamos que o texto fica todo concatenado, igualmente ao reportado pela Gabriela Silva, descrito no último comentário aqui do seu post.

Porém vi que ainda você teve que ajustar toda a tabela XML/Valid deixando igualmente ao que estava na versão 3.10, correto?

Mas no nosso caso, anteriormente pela versão 3.10, até mesmo este campo não tinha que ser feito esse ajuste para "eliminar caracteres especiais" e funcionava normalmente com esse texto e não gerava caractere algum. Abrimos até um chamado na SAP para atender isso de forma urgente, pois não está sendo possível emitir notas na Filial de MT.

No ambiente de qualidade testando agora com o mesmo texto do ambiente produtivo, retorna com a rejeição 402. E durante os testes antes do Go live nenhuma nenhuma nota foi rejeitada, após colocarmos todos os flags para eliminar "acentuação" que estava iguais na versão 3.10.

Atualmente no ambiente produtivo o erro retorna como 999 para nova versão 4.0, por isso não encontramos nada relacionado, até que depois encontramos o seu post, vi que a mensagem do seu erro era 225.

Erro atual no ambiente de qualidade, do qual não encontramos durantes os testes integrados, com o texto reportado na tag agora o retorno da rejeição é 402.

Repare que na versão 3.10 o mesmo texto passava normalmente, com as mesma configurações que fizemos também para a versão 4.0 (sem a última alteração conforme nota do qual você utilizou):

Agradeço qualquer ajuda,

Vanessa Sutil

SAP SD Consultant


config310.jpg (76.2 kB)
xml-310.jpg (90.6 kB)
xml-310-v.jpg (111.2 kB)
Share
10 |10000 characters needed characters left characters exceeded
Rodrigo Menezes May 08 at 01:23 PM
0

Olá Vanessa,

Felizmente depois de comparar e equiparar todos os registros da 3.10 x 4.00 na tabela XMLVALID não tivemos mais problemas, pelo menos em ambiente de homologação.

Me assuta seu post pois nosso go-live será no dia 13/05!

Obs.: Não precisamos fazer nenhum ajuste ABAP com relação a este problema, somente os parametros na tabela XMLVALID já resolveu.

Por favor, compartilhe caso tenha algum retorno da SAP / Resolução do Problema ! ;)

Obrigado e boa sorte,

Rodrigo Menezes

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Rodrigo, obrigada pelo retorno.

Sim resolvemos, porém aplicando 2 Notas da SAP e ajustado o XMLVALID, não foi necessário nenhuma intervenção ABAP.

O que fez a diferença foi deixar os caracteres inseridos manualmente na coluna “Elim. Caract. Não perm.” Invés de “DEFAULT”e marcar a ultima coluna “Set caract”. Marcado todas as linhas de NF-e 4.00 a coluna “Elim.acen.”.

As notas aplicadas foram: 2613668 e 2598663

*Obs.: Qualquer ajuste feito "sem o SP" na XMLVALID, será sobreposta a solução que manualmente que foi feita. Vale se atentar quando houver as aplicações de SP.

Boa sorte! Agora partiu a versão 1.50 da NT.

Att.,

Vanessa Sutil

1
Mafalda Brandao de Pinho Jun 14 at 02:22 PM
0

Bom dia

Nos testes no ambiente de homologação em MT estamos com problemas de rejeição 402 devido a caracteres especiais no XML. Fiz um teste e para a NFe homologar tive que retirar TODOS os caracteres especiais do XML via debug. Nos outros estados isso não ocorre e já estamos operando na versão 4.00.

Estamos no SP29 do GRC e fiz as configurações na tabela /XNFE/XMLVALID de acordo com a nota 2613668, porem as notas para MT ainda continuam sendo rejeitadas com o erro 402.

Abri um chamado na SEFAZ MT e estamos aguardando o retorno.

Alguém está ou ja teve este problema no MT? como solucionou?

Grato

Nilton de Oliveira

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Boa tarde!

Recebeu algum retorno da SEFAZ de MT?

Estamos com o mesmo problema.

0

Bom dia

Ainda anão recebi nenhuma resposta, porem configurei a tabela /XNFE/XMLVALID conforme abaixo e as notas estão sendo aprovadas no ambiente de homologação, na versão 4.00 do XML:

U_COM - Flag de acentos

NAT_OP - Flag de acentos e Caracteres não permitidos '"!@#$%¨&*( )_+=-`´`[]~^/?;:.,><'º

INF_AD_FISCO- Flag de acentos e Caracteres não permitidos '"!@#$%¨&*( )_+=-`´`[]~^/?;:.,><'Ǻ

INF_CPL- Flag de acentos e Caracteres não permitidos '"!@#$%¨&*( )_+=`´`[]~^/?;:.,><'Ǻ

INF_AD_PROD - Flag de acentos e Caracteres não permitidos '"!@#$%¨&*( )_+=`´`[]~^/?;:.,><'Ǻ

X_NOME- Flag de acentos e Caracteres não permitidos '"!@#$%¨&*( )_+=-`´`[]~^/?;:.,><'Ǻ

C_MUN- Flag de acentos e Caracteres não permitidos '"!@#$%¨&*( )_+=-`´`[]~^/?;:.,><'Ǻ

X_LGR- Flag de acentos e Caracteres não permitidos '"!@#$%¨&*( )_+=-`´`[]~^/?;:.,><'Ǻ

NRO- Flag de acentos e Caracteres não permitidos '"!@#$%¨&*( )_+=-`´`[]~^/?;:.,><'Ǻ

Att.

Nilton de Oliveira

0
Rodrigo Menezes Jun 14 at 07:05 PM
0

Boa tarde,

A SAP lançou a nota abaixo com algumas informações sobre este problema:

2656139 - NF-e 4.0: Rejection 225 - Batch schema failure

Abraço,

Rodrigo

Share
10 |10000 characters needed characters left characters exceeded