Skip to Content

TypeLoadException: Method 'get_HistoryInfos' does not have an implementation - revisited

Jan 19 at 04:51 PM


avatar image

I am experiencing the same problem as described and commented in:

I have tried removing all CR references and readding the ones mentioned in the article. In order to get my application running I also need to add the following dlls to my references:

  • CrystalDecisions.ReportAppServer.CommLayer
  • CrystalDecisions.ReportAppServer.CubeDefModel
  • CrystalDecisions.ReportAppServer.ReportDefModel
  • CrystalDecisions.ReportAppServer.DataSetConversion
  • CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper

I still get the error after re-adding. Any leads?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Jørgen Eriksen Jan 22 at 05:58 PM

This was a version mismatch. The referenced article in my original post has a note on this; make sure the versions are x.x.x.x.

But one thing worth mentioing: I was fooled by Visual Studio which didn't copy the dll's to the bin directory. I found out that Embed Interop Types was set to true by default on the CR references in the project. I had to set this option to false in order to be able to set Copy Local to true. This fixed the issue.

10 |10000 characters needed characters left characters exceeded
Don Williams
Jan 22 at 05:50 PM

What SP are you installing?

SP 22 was just released, read the info on SP 21, must do it...


10 |10000 characters needed characters left characters exceeded