Skip to Content

LTRC - Unable to set filter on Cluster table

Jan 19 at 01:07 PM


avatar image


I discovered that it’s not possible to set the filter on Cluster tables for process “Replication only” with DMIS 2011_1_731 sp13 .

The second row for the RFBLG table simply disappear from table DMC_ACSPL_SELECT.

What I did:

I added BSET in LTRC-> Advanced Replication Settings, using Reading Type 4 as it’s a cluster Table; the BSET has a filter on the GJAHR field.

In Advanced Replication Settings you can just set the filter for process “Initial Load Only”

The if you try to add a new entry in Advanced Replication Settings for the RFBLG , with the same filtre on GJAHR for process ‘Replication Only’ and you save, the entry disappear as soon you do refresh or leave the transaction.

The same if you try to add directly the entry RFBLG in DMC_ACSPL_SELECT in SE16. You do “save” and the entry is there, you go back and enter again the transaction and the item is gone.

So at the end in table DMC_ACSPL_SELECT I have only one record for the cluster table BSET, specific for the Initial Load process.

THen from LTRC-> Data Providing I try to run the ‘Replication’ for BSET table, and it worked fine, I mean the Initial Load has been performed using the filter I set in Advanced Replication Settings.

But then I realized that the Replication is happening really without keeping in consideration any filter on GJAHR field as expected.

So I’m wasting space on the target database for unwanted records.

How I can add the second row specific for the Replication Process and where ?

Maybe in DMIS 2011_1_731 sp13 there is another table ? What I’m missing or it’s a bug ? best regards and thanks in advance

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers