$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
0

WebIDE trial and HANA trial destination problem

Oct 24, 2016 at 08:03 AM

313

avatar image

Hi!

I have a problem with destinations and webIDE. I try to use my trial account HANA database oData service, but I get 404 "Not Found" error.

My oData service is working in address: https://iotmmsxss00XXXXXXXXtrial.hanatrial.ondemand.com/Raspberry/getTemp.xsodata/Temperature Response 200 OK. Working!

When I try to test it in webIDE I got that 404 "Not Found":

https://webidetesting0735727-s00XXXXXXXtrial.dispatcher.hanatrial.ondemand.com/destinations/HANADB/Raspberry/getTemp.xsodata/$metadata Failed to load resource: the server responded with a status of 404 (Not Found)

When I remove testing and application ID that is working fine: https://webide-00XXXXXXXtrial.dispatcher.hanatrial.ondemand.com/destinations/HANADB/Raspberry/getTemp.xsodata/$metadata Failed to load resource: the server responded with a status of 404 (Not Found)

I think something is wrong in my destination configure but I'm not sure.

My destination configure is:

NAME: HANA

Type: HTTP

URL: https://iotmmsxss00XXXXXXXXtrial.hanatrial.ondemand.com

Proxytype: Internet

Authentication: NoAuthentication

Additional Properties:

WebIDEEnabled: true

WebIDESystem: HANADB

WebIDEUsage: odata_gen

Thanks for help!

Br. Teemu K

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Bhalchandra Wadekar Oct 24, 2016 at 08:15 AM
0

Hi Br. Teemu K,

Since you are using XS OData services, you need to configure your destination to have WebIDEUsage as 'odata_xs'.

Please refer to this document: https://help.hana.ondemand.com/webide/frameset.htm?5c3debce758a470e8342161457fd6f70.html

In addition, your url should be https://webide-00XXXXXXXtrial.dispatcher.hanatrial.ondemand.com/destinations/HANA/Raspberry/getTemp.xsodata/$metadata

HANADB (WebIDESystem property) -> HANA (Name in destination)

Use name of destination while refereing to service.

Also, you will need Authentication (most probably BasicAuthentication with credentials same as you use to log into HANA) to enable access using destination: https://iotmmsxss00XXXXXXXXtrial.hanatrial.ondemand.com

Kind regards,

Bala

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi!

Thank you for answer. I did that changes and still I get same error 404 "Not Found". It is still trying to find resource from url:

https://webidetesting0735727-s00xxxxxxxtrial.dispatcher.hanatrial.ondemand.com/destinations/HANA/Raspberry/getTemp.xsodata/$metadata

Same as example odata service ES4 is working:

  1. Request URL: https://webidetesting1044471-s0015881991trial.dispatcher.hanatrial.ondemand.com/destinations/ES4/sap/opu/odata/IWBEP/GWSAMPLE_BASIC/
  2. Request Method: HEAD
  3. Status Code: 200 OK

Do you have any other ideas what might be wrong?

Br. Teemu K

0

Hi Teemu,

If url https://webide-s0015881991trial.dispatcher.hanatrial.ondemand.com/destinations/HANA/Raspberry/getTemp.xsodata/$metadata is working, then you are missing neo-app.json file.

Follow this document in case you are missing neo-app.json file. https://sapui5.hana.ondemand.com/#docs/guide/44062441f3bd4c67a4f665ae362d1109.html

Please do not hesitate to let me know if you need further assistance.

Kind regards,

Bala

0

Hi,

You can add following JSON object to your routes array in neo-app.json file:

{ "path": "/destinations/HANA", "target": { "type": "destination", "name": "HANA" }, "description": "" }

Kind regards,

Bala

0
Teemu Keskitalo Nov 01, 2016 at 12:53 PM
0

neo-app.json file was the problem. I have it but there was something wrong. Thanks for help!

Share
10 |10000 characters needed characters left characters exceeded