Skip to Content
0

Upsert (POST) into RECRUITMENT from PI

Jan 18 at 01:20 AM

139

avatar image
Former Member

Hi, I have a requirement where I have to upsert an attachment into the Candidate entity and I'm using a sfsf odata receiver channel using PI 7.4 dual stack and SFSF addon 1.0 . My upsert was successful when I tried first to insert fields like the name, but fails when I try to insert the attachment.

Because my field attachment is type Attachment I have to pass all the Attachment fields that are not nullable , this is a picture of the structure I'm sending:

If i don't give these fields with values the response is that I'm sending null metadata:

If I send values that exist in SFSF it gives :

Why do I have to give all the values when I can upsert from POSTMAN or SOAPUI giving only the fields that I want to upsert. I tried to post the json payload that I use with POSTMAN and set the passTrough parameter but it does not work. Any help is apreciated. Thank you.

xml.jpg (121.2 kB)
xml.jpg (121.2 kB)
metadata.jpg (13.8 kB)
variable.jpg (25.3 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Reena Kandula Jan 22 at 10:49 PM
0

Hi,

We had a similar issue that ODATA API does not perform upsert operation when all the mandatory fields are not passed, though works through POSTMAN. Please find the below note.

Note 2495560 - "Field required for external candidate for templateId, with the index 0" when Upserting via ODATA API - Multi Stage Application Enabled

I believe this happens in multistage application. The workaround provided in the note might help.

Thanks,

Reena

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

We have defined the fields as not required but the problem is that they are not nullable and if we don't pass a value fails with the error that metadada does not allow a null value , functional says this cannot be changed. For the time being we are using a rest channel for the upsert but we would like to use the sfsf channel. Thank you for your help.

0