Skip to Content
0

Master data load error - Command failed column index is out of range

Jan 17 at 11:03 PM

105

avatar image

Hello,

I am trying to load master data from flat file, I am getting below error -

"Command failed *COL(13); column index is out of range"

looks simple, pretty straight forward, however something seems to be missing

Transformation file mapping:

Data file: Columns in the order

I am using the DM package -

/CPMB/IMPORT_MASTER

The dimension I am loading to has no hierarchy created, is it mandatory to have a ParentH1 column for using the above package?

Error log:

transfile.png (19.6 kB)
file1.png (13.6 kB)
file2.png (6.0 kB)
error.png (16.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Vadim Kalinin Jan 18 at 08:01 AM
0

HEADER = NO, but I can see header in the sample file!

And you can see that the lines with the last column (13) with data imported OK!

Share
10 |10000 characters needed characters left characters exceeded
Leila Lappin
Jan 17 at 11:41 PM
0

Hello,

The only thing I find strange is the space in the first column value. BPC does not allow spaces in ID values. Is it possible to test this without the space in the value of the first column?

Best Regards,

Leila Lappin

Show 1 Share
10 |10000 characters needed characters left characters exceeded

It is actually "_" (underscore), image is from the file preview so not visible

0
Ellora Dobbala Jan 18 at 02:38 PM
0

Keeping the header to yes has solved the issue.

I had this weird error below so I had to switch the 'Header = No' trying different options

anyway thanks again for your Input Vadim!


header.png (4.4 kB)
Share
10 |10000 characters needed characters left characters exceeded