Skip to Content
0

SAP Gui for HTML link not working with Host Name but works fine with IP address

Jan 16 at 07:04 AM

73

avatar image

Dear Expert Friends,

We have SAP S/4 Hana backend and front end fiori server installed on a same physical server. Both system have same host name linux.suse Port number are different for backend and front end. Now if I try to launch SAPGUI for HTML service through SICF, system try to open the page http://linux.suse:XXXX/sap/bc/gui/sap/its/webgui?sap-client=400 but gets a message that "This page cannot be displayed make sure web address is correct. Now if I replace host name linux.suse by IP address link works fine and I am able to login.

Why the link is not working with host name but IP address ? How can I fix that ?

Thanks

LK

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Bartosz Jarkowski Jan 16 at 08:57 AM
1

Most probably the your computer (from which you are trying to connect) doesn't know the target server. There might be a lot of reasons why that's the case so I suggest to contact the system administrator who should be able to help you.
You can also add the missing host name to your host file by adding the IP and the hostname. A short tutorial is available here:
https://www.howtogeek.com/howto/27350/beginner-geek-how-to-edit-your-hosts-file/

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Bartosz for the response. Link is helpful. I think I need to try the fix on server.

0
avatar image
Former Member Jan 16 at 01:45 PM
0

You a check for nslookup for your server host name and FQDN of your server then you can get it checked with your domain administrator. That your server FQDN details in the Forward lookup zone and reverse lookup zone.

So that any given workstation in your LAN will be in a position to reach your server when called by hostname.

workaround is to have your local system/server hosts file should include the details.

<IP_address> <FQDN> <host_name>

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Raghavendra for the response. I still need to try the fix. I will update you soon.

0