Skip to Content
-1

Exposing SAP GW service --> SAPcpms for iOS Assistant

I am trying to consume a gateway service through the SAP Fiori for iOS SDK Assistant.

This is for a demo and I am using my SAP Cloud Platform trial account.

I have configured the SAP Cloud Connector locally on my MacBook Pro

I mapped my Virtual to Internal System in the Cloud to On Premise section

and connected my SAP CP trial account.

Configuration Steps

SAP Cloud Connector

I have configured the SAP Cloud Connector locally on my MacBook Pro.

I mapped my Virtual to Internal System in the Cloud to On Premise section

This is a SAP Gateway with HTTPS, I can ping it successfully

I finally I connected my SAP CP trial account.

SAP Cloud Platform

In my SAP CP trial account, I created a new destination that point to my SCC


SAP Cloud Platform Mobile Services (where to expose the service metadata?)

In SAPcpms for my iOS Application, I need to create a destination that will point to my service metadata file (/sap/opu/odata/sap/myService)

I can see there is an option to create destinations, you could either select an existing destination from SAP CP or create a new one

The iOS Assistant will look for a destination that point to a service not a system

I can see there is an option OData Provisioning in SCP, is it related?

thanks


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jan 22 at 02:13 PM

    Alexandre Giguere

    In "Destination Configuration" part, you can mention complete URL

    e.g. https://cg1.virtual:443/sap/opu/odata/sap/myService

    then "check connection" , if all ok then

    in Mobile service cockpit, create a destination of Type "Cloud Platform Destination" , select destination name from drop-down.

    I hope this helps.

    Regards

    JK

    Add comment
    10|10000 characters needed characters exceeded

    • ok I just found it. I had to delete some application configuration in Mobile Services because there is a maximum you can create with the trial account.

      also I had to change the authentication to basic

      thanks