Skip to Content
avatar image
Former Member

can´t load sap web ide for sap hana

Hi, i installed webide for xs advanced, and the app is running but, when i try to access to the app in https://host.com:53075, it throws a page where it say that "SAP Web IDE is not available now". i saw the console and it has a few errors, for example, "GET https://hostname:53075/che/ 404 (Not Found)" or "2018-01-16 16:10:10.656104 failed to load Javascript resource: sap/watt/ui/library-preload.js -", do you have any idea why this si happen?, regards

sap-image1.png (152.6 kB)
sap-image2.png (48.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Jan 17 at 11:25 AM

    Hi Oscar,

    I need some for information of the stack that you are working with.

    Looking at the errors, it looks like the installation didn't include the mtaext file.

    You need to download this file from the relevant release note.

    Then, install WEBIDE with mtaext file using the following XS command.

    For example, if you are working with SPS02 release:

    xs install XSACSAPWEBIDE02_6-80002257.ZIP -e sap-xsac-devx.mtaext -o ALLOW_SC_SAME_VERSION

    Make sure that the HRTT version installed is above the minimal recommended version for your WEBIDE. You can find this information in the relevant release note.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 17 at 03:17 PM

    Hi Ofer, thanks for the answer, well, i have to say that i used the mtaext, i'm workin with SPS02 and i'm installing XSACSAPWEBIDE02_6-80002257.ZIP. The difference is that i dont using the flag -o ALLOW_SC_SAME_VERSION, but, i guess that this flag is usefull when you have a older version installed, in my case i dont have installed any version. I followed all instructions in release note .

    here is the information, if you need somthing else, please let me know, regards.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 21 at 01:07 PM

    hi, can you help me with this issue?

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 23 at 02:59 PM

    Hi Oscar,

    For further investigation, if posible, I need you to attache some logs files using the following XS command:

    xs t -s SAP

    xs logs webide --all > wi1.log

    xs logs di-core --all > di1.log

    Thanks,

    Ofer

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 23 at 09:15 PM

    hi Ofer, thanks for you answer, here are the logs di1.txt wi1.txt, regards.

    pdta: i observed the errors inside logs and i think that it is a permission problem:

    the folder 80133306-d389-4295-b89c-0923fcff4eef/app appears in the log as a 404 status

    Add comment
    10|10000 characters needed characters exceeded