Skip to Content

SAP Hybris Cloud for Customer test tenant issues after creating patch

Hi All,

We have test tenant and production tenant in our landscape. We have custom solution developed in SDK. Now the custom solution is assembled and deployed to production tenant and we had to change some validations so created a patch in test tenant.

With the patch creation in test tenant it is observed that our old data in test tenant is invisible (lost) not sure. New data which gets created can be seen from SAP Hybris cloud for customer application.

Referred this blog https://blogs.sap.com/2014/10/30/enabledisable-solution-and-how-to-drive-your-customer-nuts-all-fields-empty/ and the problem mentioned is similar where data is invisible and can't activate the old solution. The blog does mention that

"Technically nothing gets lost (except the fine tuning data, because the solution got de-scoped), but the values are not visible, because they are in now invisible fields. Switching back to the original solution would also bring the data back (except fine tuning)."

We don't have a separate development tenant but really need to solve the problem with the current landscape itself. Can you please provide some pointers?

Best Regards,

Gauri

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Jan 15 at 01:02 PM

    Hello Gauri,

    Please provide me some details about your development tenant (URL, solution, ...).
    You can this info direct via PM.

    I'll try to figure out if we can "copy" the data somehow.

    Thanks,
    . Horst

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 17 at 10:37 AM

    Hi Horst,

    Thanks for your reply. As per the studio library it says that on test tenant following restrictions apply

    "Any data created for the original solution in the SAP cloud solution and any scoping decisions and fine tuning settings are not copied to the patch solution. For testing purposes, you must therefore scope the patch solution and create new test data."

    We understand with the first patch that it is deployed, we have to download the data from old solution and upload to the new solution since the namespace is changed.

    Do we need to carry out this activity for each and every patch we deploy or this is required only for first patch?

    Best Regards,

    Gauri

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Gauri,

      No, this activity is only required for the very first patch.
      With further patches the old patch would just re-opened for development with a higher version number together with the existing data.

      Bye,
      . Horst

  • Jan 22 at 08:58 AM

    Hello Gauri,

    we encountered the same problem which could be solved by uploading the patch soluiton into the original solution in the test tenant.

    This means :

    Test tenant:
    Patch solution version: 2

    Original solution version: 1->2

    Prod Tenant:

    Original solution version: 1->2

    Give me feedback if this info was helpful.

    Kind Regards,

    Johannes

    Add comment
    10|10000 characters needed characters exceeded