Skip to Content
0

Crystal Report Fields are empty.

Jan 12 at 02:34 PM

26

avatar image
Former Member

I have several web sites that have been working fine for several years on a windows 2003 server. I am using visual studio 2008 and the code is written in visual basic and crystal report 10. I have a new server that is running windows server 2012. I copied all the web sites from the 2003 server to the 2012 server and they all work fine except for crystal reports. All the reports on all the web sites have the same problem. All the fields in the crystal reports are empty. The reports display but the fields are empty. When I run a web site via visual studio 2008 using debug on the windows 2012 server the fields are filled with the correct data. Is there some kind of permission that needs set? Any help would be GREATLY appreciated.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Don Williams
Jan 12 at 02:43 PM
0

Hello

Likely because CR for VS 2008 was never tested on that OS.

I suggest updating to VS 2010 -> 2017 and using the only CR .NET SDK that is supported and maintained now.

You can get it from here:

https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

One issue may be because you are not using Sessions and Postback methods to keep the report in scope. Or your WEB site can't find the Viewer folder or doesn't have access to it, requires full read/write permissions.

Use Fiddler, it should say what's missing...

You also need to move the CR code from Page_Load to Page_Init.

Don

Share
10 |10000 characters needed characters left characters exceeded