Skip to Content
0

Getting error "No applicable data found " while executing BI query in both Bex and Portal

Oct 22, 2016 at 06:17 AM

151

avatar image

Hi All

I am from SAP Security background, users are getting "No applicable data found " while executing query for particular selection.
There is no issue users who are having * access and we also checked with BW functional team,they informed that they are able see data and data is exist in cubes.

User is having access for that particular selection, even in trace also it is not showing any access issue. Moreover user was able to execute report with same access and suddenly this error is coming.

Please help me to sort out this issue.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Rajesh Naik
Oct 23, 2016 at 10:19 PM
0

Hi Madhu,

Was there a change in the design of the report?

Thanks,

Rajesh

Share
10 |10000 characters needed characters left characters exceeded
Vengal B Oct 24, 2016 at 08:43 AM
0

Hi Madhu,

Ask user to access same report in his/her colleagues machine with his/her credentials. Does user has personalized variables saved for that report, if yes delete personalized variables and try to run query freshly.

Did you check user authorization in BW system using RSECADMIN t/code for that particular report with same selections.

Thanks,

Vengal.

Share
10 |10000 characters needed characters left characters exceeded
Raman Korrapati Oct 25, 2016 at 08:40 AM
0

Hi,

No Applicable data found - mean the selections which is entered by user does't have data at bw target level or user may be passing wrong format input values. please take bw consultant help and check the user input values which is he/she is entering.

Thanks

Share
10 |10000 characters needed characters left characters exceeded
varun jain Oct 26, 2016 at 11:11 AM
0

Hi,

I would suggest to run both trace ST01 and RSECADMIN and see if there is something failing as per user's report execution. Still if you don't see anything in the trace then sit with BW consultant to find out if user is executing the reports correctly with right selection of parameters.

Also try to execute the report from your id and run the RSECAMDIN trace with different value of variables.

Hope it would help.

Thanks,

Varun

Share
10 |10000 characters needed characters left characters exceeded
Wojciech Matulewicz Nov 03, 2016 at 06:30 AM
0

Hi,

Did you checked query execution in RSECADMIN (running query in RSRT in user context) ?

best regards,

Wojtek

Share
10 |10000 characters needed characters left characters exceeded
John Hawk Nov 03, 2016 at 02:02 PM
0

Hi Madhu,

My guess would be that you have recently modified (or imported a transport) a change to the security profile for most BW users.

This change resulted in no matching data ( Company Code = 1000 AND Company Code = 2000) vs. (Company Code = 1000 OR Company Code = 2000) . The first would have "no applicable data", the second would return data.

Have a BW resource review the profile to insure the the profiles are not overrestricted.

John Hawk

Share
10 |10000 characters needed characters left characters exceeded