Skip to Content
avatar image
Former Member

RFC connection R/3 to XI error.

Hi All,

Iam doing a scenario from RFC-XI-Webservice.

I have configured the rfc sender communication channel.

I have created an rfc destination in r/3 pointing to the XI server with a registered program id.

Created an rfc dest in r/3 server pointing to itself with program id.

this is same given in cc for the rfc.

When i run my scenario..the cc is in green status, but there is no message(error or success) into moni.

do i need any connection settings in the XI server in sm59?.

there is a tcp connection to the r/3 server in sm59 in XI and works fine.

Do i need snc parameters?.

refered to blog /people/michal.krawczyk2/blog/2005/03/29/configuring-the-sender-rfc-adapter--step-by-step and /people/shabarish.vijayakumar/blog/2008/01/08/troubleshooting--rfc-and-soap-scenarios-updated-on-20042009

Do i also need any config to be done in my custom rfc?..its remote enabled.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    May 01, 2008 at 06:39 PM

    hi friend,

    I got the similar problem too, where adapter showing green color and with no messages processed.I could figure out the problem.

    1. go to SXMB_MONI and see the message status (a).processed (b)scheduled for processing (c) or error

    since adapter engine is showing green color it must be showing b.

    2 If this is the case check both payloads inbound and outbound in the SXMB_MONI double click the message.

    3 check for the status of the message queue, refresh the queue then it should show the output.

    regards

    praveen

    Add comment
    10|10000 characters needed characters exceeded