Skip to Content
0

WEB IDE Error "Authentication Failed for the selected system"

Jan 10 at 09:46 AM

433

avatar image
Former Member

Hi All,

I am creating Fiori App as a trial with WEBIDE, referring to https://blogs.sap.com/2015/07/27/creating-and-deploying-sap-fiori-app-dc-exercise-part-1-of-3/.

Even though I set NoAuthentication for the destination, an authentication popup appears when selecting a destination in Data Connection step. After closing the popup, the error message "Authentication Failed for the selected system" shows up.

Could anyone know how to deal with this issue?

Best Regards,

Yudai

error.png (108.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Ivan Mirisola
Jan 10 at 06:41 PM
1

Hi,

Get an account using this tutorial first:

https://www.sap.com/developer/tutorials/gateway-demo-signup.html

You will notive ES4 system is being retired and replaced by ES5. I believe for your Web IDE exercise it will make no difference and thus it will be safe to use ES5 instead. The registration link will give you hints on how to create an account on ES4 if you feel lucky :-).

Regards,
Ivan

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you so much. It has been solved.

0
Ivan Mirisola
Jan 10 at 03:29 PM
0

Hi Yudai,

You need to provide user/password authentication to that particular service or even to call system ES4 to search the odata service catalog.

ES4 is a "public" ABAP system provided to developers, but it requires you to request an account first. If you have already done it, check you can call the following URL:

https://sapes4.sapdevcenter.com/sap/opu/odata/IWFND/RMTSAMPLEFLIGHT/

It should return an XML with the service metadata.

I believe the easyest way is to enter your credentials for Basic Authentication for destination ES4 instead of using NoAuth mechanism.

Regards,
Ivan

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you for the answer.

Do you know what credential we need to enter for es4? I tried to enter my SID but it didn’t work.

0
Michal Keidar
Jan 13 at 03:34 PM
0

Hi,

Setting "No Authentication" means exactly it. It means you as a user does not provide any authentication in the destination.

So the browser "takes care of it" and pops-up this popup. This is the expected behavior.

You can choose "Basic Authentication" and then provide your system credentials in the destination. Then the browser will not raise this popup.

Regards,
Michal.

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi,

in my settings I have "BasicAuthentication". But the Pop-Up (see first picture from Yudai) appears. Do you have any notes?

Regards,

Serkan

na.png (10.6 kB)
0

Maybe your credentials are incorrect

0