Skip to Content
avatar image
Former Member

Problem opening a database more than once with Clipper and ADSDOSIP on ADS 11.1 trial server

Hi.

I have multiple Clipper applications with ADS 7 on Netware 6 server using IPX protocol. We are looking to transfer the applications from the Netware server to a Windows server. To this end, I have acquired a trial version of ADS 11.1, instaled it on a Windows 2008 server, have linked my apps to switch to IP protocol and use ADSDOSIP on the client workstation.

When I execute some of the applications connecting to the ADS 11.1 server, I can only open a particular database once. If I try to open it a second time, I get an error. When I execute the same applications connecting to the ADS 7 server, all is fine. Same data, same executable. The only difference is the ADS server connecting to.

Any help would be greatly appreciated. Thanks.

Denis Lamothe.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Oct 21, 2016 at 06:26 PM

    Never mind. I've figured out the answer.

    In the Advantage Configuration Utility application, under the Configuration Utility tab, you'll find the Misc. Settings tab. Check the Non-Exclusive Proprietary Locking.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 12, 2017 at 05:06 PM

    Hi Denis,

    I'd like to know if you have the DISCONN.OBJ file for Clipper on ADS. It disconnects users from ADS when bases are closed.

    Thank you.

    Jose

    Add comment
    10|10000 characters needed characters exceeded