Skip to Content
avatar image
Former Member

How do I change icm/keep_alive_timeout ? (SMICM won't let you do it.)

In SMICM (Go To -> Parameters->Change), you can change the vvalue of icm/conn_timeout from its default value of 5000 msec.

But the transaction won't let you change the value of icm/keep_alive_timeout from its defailt value of 60 seconds, even though the documentation for the parameter says you can override it. (The "new" value column entry is grey instead of yellow.)

So how DO you change icm/keep_alive_timeout if SMICM won't let you change it?

I am pretty sure it's this parameter that is resulting in the following message when I attempt to run a WDA demo application:

500 Connection timed out

Error:	-5
Version:	7000
Component:	ICM
Date/Time:	Tue Apr 29 03:32:38 2008
Module:	icxxthr_mt.c
Line:	2698
Server:	dhalitsky-l_DEV_01
Error Tag:	{-}
Detail:	Connection to partner timed out after 60s

(Remember, I'm trying to run the subscription stack in 750M under VMWare on a laptop with only 1G total RAM.)

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 29, 2008 at 04:27 AM

    you can change the profile parameter value from transaction RZ10 --> choose instance profile -> extended maintenance.

    after changing the value from RZ10, for it to take effect, you have to restart the app server.

    Regards

    Raja

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 29, 2008 at 05:34 AM

    Hi Raja -

    Thanks for that tip!

    I did it the way the help library says - by editing the start-up profile for the instance and changing timeout and proctimeout on icm/server_port ...

    But your way is a lot nicer - I'll try it tomorrow.

    djh

    Add comment
    10|10000 characters needed characters exceeded