Skip to Content

Default input values for BAPI

Hey all,

I have a little model where all the input parameters of a BAPI are in a form.

This works fine.

No some of the input parameters should be default and not be visible for the user.

I thought I needed the 'Start point' to do that, but it doesn't work.

All the input parameters in my form are still working, but all the input parameters in the start point are ignored.

For the start point parameters, I added the default values into the configuration, and used single quotes. (I've also tried double quotes).

Can anyone tell me what I'm doing wrong.

Thanks

Steven

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 29, 2008 at 03:24 AM

    Hi,

    To get the default values in input fields.Give them in thier property window under General Tab.

    To make them invisible i.e to hide ,Check the Hidden check box in the propert window under General Tab.

    Regards,

    Govindu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 28, 2008 at 06:59 PM

    Steven,

    you can add your input fields to the input form you created, then assign them a default value and make their visibility hidden.

    Regards,

    Ahmed Salah

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 29, 2008 at 12:43 PM

    I agree, that you can use visibility condition. But it does not solve your problem if you want to default values BEFORE submit.

    I had the same problem with Start point. Hope someone can clarify why Start point is not working properly.

    /jakob

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      on whcih SP you are working and if start point is not working means it may be bug with that SP.

      Can you give the Steps how you designed your start point?

      Regards,

      Govindu