Skip to Content

Error While Deploying UI5 Application to SAPUI5 ABAP Repository

While deploying the the UI5 application for the first time , I'm getting the error "SAPUI5 component sap.m used in SAPUI5 application does not exist" same error is for sap.ui.core library and sap.ui.layout . My backend server version is 1.44.25 and application version is 1.44.27 . While deploying the application , in wizard message was shown that Application is compatible with backend .

Kindly Help me how can i resolve the above mentioned issues ..

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jan 10 at 04:33 PM

    Hi Manish,

    Same question as this one:

    https://answers.sap.com/answers/280255/view.html

    Check the report and sap note stated on this answer to make it work.

    Regards,
    Ivan

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 10 at 12:41 PM

    Can anyone help me in this issue as it is urgent

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 11 at 03:17 AM

    Hi Ivan,

    Thank for your comment .

    I checked the given link before posting the question . In that thread they talk about running report /UI5/APPINDEX_CALCULATE which does not exist in my system .Also the note is completely based on the report .

    Regards,

    Manish

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 11 at 10:27 AM

    Hi,

    First we have to run /UI5/APP_INDEX_CALCULATE report then try to deploy the application .

    Regards,

    Manish

    Add comment
    10|10000 characters needed characters exceeded