Skip to Content

Light weight add on not installing on client machine

Jan 10 at 01:25 AM


avatar image

HI all,

I have deployed a light weight add-on through extension manager for SAP 9.2, in the server the add-on is installed and works as expected. But in client machine, the add-on is not getting installed.

I tried all of these,

  • Un-assign and re-assign the add-on to the company
  • Check the SAP Client agent is running
  • Remove the AddOnsLocalRegistration.sbo and AddOnsInstall.sbo files
  • Check company/server
  • Set add-on as mandatory

We have 2 add-on's that uses ARD instead of extensions to register and these add-on's are installing correctly without any issues.

I have even tried to copy the add-on folder and the AddOnsLocalRegistration.sbo from server to local and surprisingly found that SAP is uninstalling the addon when i log in. Users are using SSO to sign in to SAP B1.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Sinoj George Jan 15 at 01:28 AM

This is an issue in SAP. Note: 2467361

Symptom In your SAP Business One application, you have enabled single sign-on and you have assigned several lightweight add-ons using the Extension Manager. After you bind a SAP Business One user with a Microsoft Windows account, the lightweight add-ons disappear from the Add-On Manager.

Cause Application error

10 |10000 characters needed characters left characters exceeded