Skip to Content
0

Do PowerDesigner UI profiles really work

Oct 21, 2016 at 02:44 PM

38

avatar image

I've set up a simple UI profile in the Repository, which adds a simple toolbar and a menu, as an experiment for a client. I've assigned this profile to a user, connected to the repository as that user, and the new menu and toolbar just don't appear. Has anyone got this functionality to work?

In the Help on this topic, it says that customised UI profiles are "made available to users on their first connection to the repository". Only the first time?

10 |10000 characters needed characters left characters exceeded

Strange, I added the UI profile and an object permissions profile to my own user, and they worked :)

They didn't work for a user that had minimal access to the repository - they couldn't even list the contents of the Library. When that user connects to the repository, PD reports 'there is no glossary in the repository', even though they now have Read access to the whole Library, and List access to one other top-level folder. As a further test, I created a new user that has Submit access to the Library and Full access to a top-level folder - they also can see nothing in the repository. The other user is three years old.

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

George McGeachie Oct 23, 2016 at 04:34 PM
0

I reckon the UI profiles work fine. I just have issues with repository users instead.

By the way, there doesn't appear to be any way of marking this as 'answered' or 'closed' in this new site.

Share
10 |10000 characters needed characters left characters exceeded