Skip to Content

Solution Manager: Suppressing alerts during the night.

Jan 08 at 11:28 AM


avatar image


I'm currently doing some work setting up some System Monitoring in Solution Manager. Our non-production systems will be shut down during non-peak business hours (hosted by AWS so it's a cost saving exercise).

What I don't want is a bunch of alerts every night saying systems are not available. I've looked into work modes but the only work mode that appears to expect the system to be down is "Planned Downtime". And this looks to be set on a day by day, hour by hour basis.

I don't really want to manually entering planned downtime for multiple systems for each day of the week for the next XX years!

The other work modes seems to expect the system to still be up and therefore will alert when the system is stopped.

Has anyone had any experience with this? Surely there is a way to prevent alerts on a schedule??

Thanks in advance for any help.

10 |10000 characters needed characters left characters exceeded

This is Solution Manager 7.2 by the way.

* Please Login or Register to Answer, Follow or Comment.

2 Answers

Stijn De Regge Feb 14 at 03:01 PM

Hi Paul,

you need to do a couple of things to get this working

  • in your System Monitoring scenario, Configure Infrastructure - Workmode Settings, you can select for which WM type your monitoring is active. I would suggest "no workmode configured" and "Peak Business Hours" as enabled.
  • Create a Technical Scenario of type Work Mode Management, and include all your non-production Technical Systems and Databases
  • Go to Work Mode Management, choose your scenario, and schedule a Non-Business Hours workmode, defining a recurring weekly pattern where you define each day when your non-production hours are occuring. You can set the End Date years in the future, so that this workmode is active for the coming years.

Your systems will then enter the Non-Business Hours workmode at the selected time, and your Solution Manager will stop monitoring those systems when they are in that workmode.

10 |10000 characters needed characters left characters exceeded
Yogesh Patel
Feb 21 at 05:44 PM

Hello Paul Ashton,

Please refer SAP note below

2468223 - How to configure work mode specific settings for the Alerting in SAP Solution Manager

Thank you


10 |10000 characters needed characters left characters exceeded