Skip to Content

SAP Design Studio - Prompt Issue - "Master Data"displayed and not “Only Values with posted data"

Hello all,

I have an issue with the variables’ values displayed in the Design Studio Application Prompt.

Environment:

  • SAP NETWEAVER 7.4 on HANA Database
  • SAP BusinessObjects Design Studio 1.6 SP6 Patch

Problem Description:

I’m using an input ready query with the filter characteristic properties: “Only posted values for navigation”. When the query is executed in BEX Analyzer the filter selection is applied, and only posted values are displayed as it is selected in the query properties.

This query is used as a Data Source for a Design Studio Application. In the application -> Data Source ->Initial View, all the mandatory variables which are used in the prompt menu, have the following selection checked: Members for filtering -> Only Values with posted data and Members in result -> Only Values with posted data.

When the application is executed on the BI Platform and the Prompt menu is displayed, all the variable “Master data” is loaded, instead of “Only Values with posted data”. The members for filtering defined in the Initial view are discarded and not applied when running the application.

I assume, this is a Design Studio issue as when the query is executed in BEX Analyzer the filter selection is applied accordingly.

Could you please assist in solving this issue?

Please let me know if you need any additional information.

Than you in advance,

Cristina

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 07 at 05:04 PM

    Hi Cristina - SP3 for Design Studio is more than a year old; please patch up to the latest SP for 1.6

    Even SP4 says it fixes issues with prompts - see https://launchpad.support.sap.com/#/notes/2330273

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Tammy,

      I have patched up to SP4, but the issue still appears, the master data it is loaded in the prompt, instead of posted values.

      Thank you and best regards,

      Cristina

  • Jan 13 at 10:43 AM

    Hello Tammy,

    I had upgraded to DS1.6 (SP6), but this didn't solve the prompt issue, the master data is loaded in the prompt application and the query, filter characteristic properties: “Only posted values for navigation” are transferred to the Design Studio application.

    Could you please provide another solution?

    Thank you and best regards,

    Cristina

    Add comment
    10|10000 characters needed characters exceeded